Keyboard error : Asus P3V4X

Hot-swapping and Boot-Block flash & Boot block flash and floppy support
Post Reply
New visitors - please read the rules.
Posts: 4
Joined: Tue Jun 18, 2002 3:19 am

Sorry this is so long!

Symptom: when trying to boot up my computer it hangs up during POST with the message 'keyboard error or no keyboard present' (see below) and goes no further. If I press a key the case speaker then begins emitting a continuous very fast series of beeps (more like 'ticks' really). I cannot get into BIOS because the keyboard isn't recognized. Prior to this I also had a problem with the mouse not being recognized, but at least I could boot into Windows. To 'get round' the mouse problem I installed a USB mouse. Unfortunately at this time I also shuffled some PCI cards around because I thought I might have an IRQ conflict. I may have been a bit rough with the motherboard! Tried to reboot but have been unable to. I have removed and replaced the CMOS battery but the same problem persists. I've tried a different PS/2 keyboard with the same result.

I wonder if I've damaged the motherboard – maybe the keyboard controller chip.

Would a serial keyboard plugged into COM1 or a USB keyboard allow me to boot up? Does the POST look for a keyboard in other ports if it can't find one in the PS/2 port? If only I could get into BIOS I could bypass the error halt condition as described below.

Any help would be very welcome.
Asus P3V4X motherboard, Award BIOS v.1005, VIA 4-in-1 drivers
Pentium PIII 600E
256 MB Crucial PC133 SDRAM
Seagate 40 Gb ATA100 7200 rpm hard drive
nvidia RIVA TNT2 32 MB M64 AGP graphics
Soundblaster 4.1
Conexant PCI modem
PS/2 Microsoft Intellimouse (+ USB Packard-Bell mouse)
PS/2 Dell Keyboard
Windows 98SE

The whole system was working fine until I messed around with mouse drivers!

Keyboard error or no keyboard present - Cannot initialize the keyboard. Make sure the keyboard is attached correctly and no keys are being pressed during the boot. If you are purposely configuring the system without a keyboard, set the error halt condition in Setup to HALT ON ALL, BUT KEYBOARD. This will cause the BIOS to ignore the missing keyboard and continue the boot
BIOS Bodhisattva
Posts: 3145
Joined: Fri May 03, 2002 10:34 am
Location: Thames Valley, UK

If you've been a bit rough with the motherboard, could you have either lost a screw somewhere or somehow made contact with the chassis ? It may be worth taking the board out of the case and testing it on the bench.
I assume from your description that the keyboard lights still light (if only briefly) on power-on so the keyboard power fuse (if present) is OK.

Try removing both mice and plugging the keyboard into the PS/2 mouse socket. Some BIOSes allow this.

Are you sure you removed the CMOS battery for long enough to lose all data ?

Whether a USB keyboard would work I can't guess. Serial keyboard support ? I doubt it.
Tested patched BIOSes. Untested patched BIOSes.
Emails *will* be ignored unless the subject line starts "Wim's BIOS forum"
New visitors - please read the rules.
Posts: 4
Joined: Tue Jun 18, 2002 3:19 am

Yes, I've tried firing it up with the motherboard isolated from the chassis. There were certainly many P3V4X boards sold which had a grounding/shorting problem causing keyboard/mouse errors (a quick search in Google Newsgroups confirmed this) but that doesn't seem to be the case with mine. What I meant by being rough with the motherboard is that I had a helluva job getting one of the PCI cards fully inserted into its slot - had to push/wiggle a lot, then it went in with a bang. Maybe cracked the board (can't see a crack though) or broke a soldered joint.

The keyboard lights illuminate and STAY lit up.

I'll try the keyboard in the mouse socket, interesting idea. I'm also going to buy a USB keyboard and give it a shot. If it doesn't work maybe DABS will take it back. The Award BIOS has native USB support, and USB is enabled in BIOS so it might work.

I admit I only removed the CMOS battery for a short time (seconds). The P3V4X doesn't have a CMOS reset jumper, though there are apparently two contacts on the board you can short out to reset CMOS if you know where they are! They're not on the mobo diagram in the manual. I'll try taking the battery out and leaving it out for a few hours.
Post Reply