#15170 by Irfy
Thu Mar 27, 2003 4:19 am
THIS POST IS HUGE :( , and I have a reason. I'm trying to be as complete as possible, so forgive me the length of this post. The stupidest thing I could have written is "My board's dead, oh my God!".

Ok, let's just say I've read the most of the relevant posts and still have a few questions.

Specs:
#Destroyed:
-Chaintech 6AIV0 (VIA PLE133 (8601A) + VT8231)
-BIOS Chip info from the sticker: Phoenix BIOS D686 1998 016644572.
-BIOS (manufacturer) info from under the sticker: EON EN29F002NT (+ some stuff that I had no use of with UniFlasher). it is a 256KB (2MBit) ROM

#Hotflash:
-ECS EliteGroup K7VMM+ PCB 3.1 VIA ProSavageDDR KM266, VT8375 NB + VT8235 SB
#Note: I admit that this northbridge is NOT listed in http://www.pppr.sk/rainbow/uniflash.txt. That making a problem?
-BIOS: AMIBIOS, doesn't really matter much, I remove it anyways. or does it?

History:
-ran an awdflash.exe utility just to see if it works. did nothing, just tried to exit after the GUI appeard. couldn't. cold-restarted. nothing appeared on the screen, no sounds.
-after a few resets, the board started producing sounds. still nothing on the screen.
-a new PCI (! yes, PCI, not ISA) video card gave me output concerning the Award BootBlock. never made it to work properly with anything like DOS6.22 or win98SE (latter not supposed to work?)
#Note:the PCI video card wouldn't give any output if the LAN card was taken out. how beautiful.
*Q:Am I supposed to make a DOS boot disk (like 6.22) to make it boot at the bootblock, or is it no IO.SYS, no MSDOS.SYS and no COMMAND.COM, just the flasher? This makes no sense to me, but a post around here made this implicit assumption. Just trying to clarify.
-I tried the hotflash, couldn't work with any standard tools
-tried the hotflash with uniflash. now come the questions:
*Q:I have a BIOS chip that is not like the one depicted on http://www.pppr.sk/rainbow/hardware/hotflash.html it is the one that has pins on all four sides and is smaller. a total of 9+7+9+7=32 pins. makes any difference?
*Q:As can be seen, UniFlash supports EON EN29F002T, but mine is EON EN29F002NT. In section 3.1 of http://www.pppr.sk/rainbow/uniflash.txt it says something about the N in the name of the BIOS chip, but I don't understand it. does it make any difference?
*Q:am I supposed to use the EN29F002T routines to flash my EN29F002NT?
-Ok, I've tried to flash four different versions of my BIOSes forcing EN29F002T and tried a couple of times forcing with the other EON chips. Each time there would be a write verify error.
#Note: different BIOS versions gave different bad sectors. 3 out of 4 gave more bads than goods, and one gave the first half good, and 3 errors in the rest.
-Tried the erroneously flashed BIOS in the original motherboard, still stuck at BootBlock with the version that did more good sectors than bad, with others, absolutely nothing.
#Note: I AM using the Advanced menu to overwrite BootBlock
-Tried many combinations: get the Backup, put it back, also for BootBlock, worked with success - couldn't boot again of course. new bioses - no way.

I believe that this *could* be a bug in the program itself - different bad sectors for different BIOS versions - however, not necessarily. Could be a hardware malfunction, phisically damaged BIOS (while taking it out of the socket :? ) - especially taking into account that the data on the BIOS chip can be backuped and reflashed back - without an error, and new data - not.

Any suggestions?

The site has been helpful already. Thanks.

Irfan Adilovic

---------------------
read on if interested in why I "just wanted to see" if the flash utility works - in the first place :!: .

-A friend called to fix her comp, wanted WinXP
-Needed memory, bought a one side, four chip 128MByte module, couldn't get it recognized
-tried to get a BIOS update, yeah right, try http://www.lucky-star.com.tw yourself.
-found two BIOSes from some other resources after making 1/1 sure about the exact motherboard model.
-the budled awdflash tool would hang during the backuping of the BIOS or after printing out the command line. 1/1 agree with PvL and Rainbow about the awdflash tool.
-then, from a non-intutive reason, I thought, "maybe there's something about her computer. let's try it on this one, her roommate's".

that is how everything began. I am aware about the memory forums, and I am pretty sure that it's the chip density problem. the system just runs fine recognizing 128MByte module as a 64MByte one.

Now this girl whose machine is "down" wants a solution by "tomorrow" and I had to order a new Socket370 motherboard, but companies just have problems getting those boards in under a week these days, so I need to try a little bit more.

Anyone has an idea of how I could get a BIOS chip replacement in Austria, Wien? Tried a few companies, their answers were usually "we don't fix that" or "we can't order that chip, because it's for an obsolete motherboard". Any further advices? Gonna try eBay. Notice: I don't have a credit card.

Bottom line. Never fix a girl's computer.

Irfan Adilovic
------------------
"Only those who do nothing do not make mistakes."
As if "doing nothing" was not redefined with the awdflash tool...