Award flash erases BIOS just by reading?

Questions that don't belong in the other forums.
Post Reply
larrymoencurly
New visitors - please read the rules.
Posts: 8
Joined: Fri May 31, 2002 8:33 pm

I have a Soyo SY-6bb v. 1.0 motherboard (Intel 440BX) that loses its BIOS a couple of times a year and boots into boot block mode. For a long time I didn't know why, but I think it happens only when I ran the Award flash program v. 7.xx the day before. The odd thing is, the last time I ran this program, all I did was make a backup of the BIOS. I once tried changing the BIOS chip to a different brand, but this didn't seem to help. This also has never happened with my other motherboards. I'm sure that I don't have a virus or power supply problem (swapped supply with one of the computers that's never crashed its BIOS). This motherboard doesn't have a jumper or BIOS setting to prevent flashing the chip.

Does AWDFLASH /PN /SY do anything that can erase a BIOS, if not immediately then later on?
edwin
The Hardware Archivist
Posts: 6274
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

me thinks a typing error and those are easily made...
edwin/evasive

Do not assume anything

System error, strike any user to continue...
Rainbow
The UniFlasher
Posts: 3122
Joined: Wed Mar 20, 2002 4:16 pm
Location: Slovakia
Contact:

Awdflash is crappy - some versions do stupid things. I corrupted BIOS on Mercury/Kobian board with SiS630 chipset and EON EN29F002NT Flash ROM several times by just running older version Awdflash and exiting! It identified the chip incorrectly and somehow corrupted the data. It happened at least three times until I found what causes the problem :) Finally I made UniFlash working on SiS630, so I hope that I will never use Awdflash on this board...
Patched and tested BIOSes are at http://wims.rainbow-software.org
UniFlash - Flash anything anywhere
Post Reply