Questions that don't belong in the other forums.
#34669 by felchi80
Mon Oct 31, 2005 8:51 am
Ok, I hope someone here can clear things up for me a bit.
I have two boards here, an A7N8X rev.1.04 (bought used) and an A7N8X-E Deluxe (working perfectly).
It seems that both boards have the same bios chip... it's a PMC PM49FL004T.
Now, there are places that say that these boards have either a 2mb chip or a 4mb chip.... most likely... deluxe models have 4mb and others have 2mb. So now this is weird. It seems that my A7N8X rev. 1.04 has the same bios chip as my deluxe model. so maybe someone might have changed the chip on it and loaded with an A7N8X-Deluxe Bios! Which is having trouble reading the correct cpu temperature right now. and causes the computer to shut down.

The second thing which i'm confused about is that the bios files from asus are all either 256KB or 512KB, the latter being for deluxe models. So what is this about? 256KB bioses use 2mb chips and 512KB use 4mb?
Anyway, so I tried flashing the correct 256KB bios onto the
PM49FL004T chip... and it didn't work. awdflash just freezes right before flashing. also, i tried using uniflash, which at first didn't allow me to flash because of a "size" mismatch? and then i tried forcing it by specifying the rom to be PM49FL002 so that it would allow me to flash the 256KB bios. Forcing the flash did work but the verification failed. So I just restored the backup bios.

So my questions are:
what's the relation between bios file sizes and chip sizes?
are PM49FL004T 4mb chips or 512KB chips?
Do A7N8X rev 1.04 use 4mb(512kb) or 2mb(256kb) chips?
Can 256KB bios files be flashed onto 4mb (512kb) chips?
should I get a real PM49FL002 blank chip (or any other compatible 2mb/256kb chip) to flash the 256KB correct bios file?

Thanks in advance.