Questions that don't belong in the other forums.
#56103 by jmchapel
Sat Dec 11, 2010 3:54 am
I have an old MSI K8T NEO 2 motherboard, worked for years, but stripped it and haven't used it in about 4 months. Trying to get it to work again, but when I boot it up it says "BIOS is not installed!". I assume this is an error because it would just bring up a cursor if it really wasn't installed. I am relatively new to BIOS slang and configuration, but this is what happens. It boots up and says BIOS is not installed, then it brings up, "Press F-10 to access Gigabit Boot Agent", then if I don't press anything it brings up "Boot Error-Insert Diskette in A:". I downloaded amiflash and drdflash, put them both seperately onto two different floppys with DOS boot sequence and the latest version of the BIOS for my motherboard onto the floppy. While I am in DOS I run the BIOS exe file from the MSI website. It brings up, "AMI FLASH programming Utility For DOS Ver.7.00.15" and gives me a bunch of options:

<COMMAND>
?:Help
-B:Disable Boot Block Programming
-N:Disable NVRAM Block Programming
S:To save Flash ROM data into file AND quit.

It continues a little longer, but not sure its that relevant seeing as when I attempt input these commands "A:/> L" nothing happens, it says bad command or file name. If I try to run the AMIFLASH after I unzipped it to the floppy it says my System BIOS does not have Flash Support.

I chose to flash the BIOS because I am not able to instal an OS to any of my drives, it says boot failure on both my Vista and Windows 7 disks and goes straight to disk A. Any ideas on how to 1.) flash/reinstal/whatever to the BIOS 2.) skip the BIOS step to instal an operating system. Like I said the computer worked fine 3-4 months ago and now this BIOS problem. Any help is appreciated, if you need more info let me know. Thanks



Mike