Questions that don't belong in the other forums.
#42920 by qrstuv
Fri Jan 05, 2007 8:44 am
I have an ASRock K8upgrade-VM800 motherboard. I'm running AMD 64 3400+, ATI Radeon 9200SE, Seagate and Hitachi Serial ATA hard drives.

The current BIOS will not boot from SATA drives. I decided that the BIOS was probably old and I tried to upgrade. I went to ASRock website and downloaded the flashing utility and the latest BIOS. I created a boot disk, copied the files, and attempted to flash my motherboard. I got this error:

Error: The BIOS ID not found, this utility may not be used for this system.

I tried several other flashing utilities, including AWARD (the kind of bios currently on there) AMI, and UniFlash (which did absolutely nothing). These flashing utilities told me that the BIOS that I was trying to upgrade to was either not an AWARD BIOS or did not match the brand of the utility I was using. I also tried updating to all previous versions, all giving me the same error messages. I can't update through Windows because I am running KUbuntu linux, and I can't boot off my drives to begin with. I'm completely lost. Please help.