PC Chips M583lmr (V1.3): BIOS and Flash utility

Questions that don't belong in the other forums.
Post Reply
Lotosdrache
New visitors - please read the rules.
Posts: 7
Joined: Sun Feb 24, 2019 11:17 am

Sat Sep 07, 2019 3:24 pm

Hello

I've got a PC Chips M583lmr motherboard and need a BIOS update as my AMD K6-2+/570ACZ isn't recognized correctly and the internal ArtX graphic has some problems under DOS at a resolution of 640x480 pixels.

P.O.S.T screen:

Code: Select all

American Megatrends
AMIBIOS (C)1999 American Megatrends Inc.,
Release 09/25/2000 S

62-0925-001437-00101111-071595-ArtX-M583LMR-0
Southbridge:
ALi M1543C B1

What I've done so far:
I found some BIOS files at
http://www.elhvb.com/mobokive/Archive/P ... index.html
and
https://www.driverguide.com/driver/deta ... rid=214801
- 2k0828s.rom
- 2k0925s.rom
- 010306s.rom
- 010525s.rom
and tried to flash them. However, no flash utility worked.

The manual (Be careful, file contains macros!) says:
"BIOS Update Utility
The BIOS Update utility allows you to update the BIOS file on the mainboard to a newer version. You can download the latest version of the BIOS setup available for your mainboard from the website.
• D:\UTILITY\AMIFL818.EXE"

So, I downloaded this version from here. But when I ran the program it told me:

Code: Select all

> Chipset/Flash part isn't available. The function will be invalid.
Then, I tried version amf895.exe:

Code: Select all

The Chipset is not supported

Press any key to continue...
and then the next message was

Code: Select all

Flash is wirte-protected

Press any key to continue...
I cannot find any jumper on the board or any option in the BIOS that wirte-protects the BIOS chip. Therefore, I guess this version doesn't work, too.

Then, I tried AMIFL634.COM:
The program didn't show any information right below under "Flash information". When entering the name of the BIOS file the following message appeared

Code: Select all

Reading BIOS File from Disk...
but nothing further happened. So, I pressed RESET 8O and restarted the system . It was still functional...

Then, I tried AFUDOS.EXE v4.40:

Code: Select all

- ERROR: BIOS does not support AFU.
Now, I am at my wit's end.

Please, can you help me and provide me with an updated BIOS file and a working flash utility?
Lotosdrache
New visitors - please read the rules.
Posts: 7
Joined: Sun Feb 24, 2019 11:17 am

Sun Sep 08, 2019 3:21 pm

I solved it myself overnight:
aminf342.exe worked with this board.

Sorry for wasting your time :oops: :D
edwin
The Hardware Archivist
Posts: 6227
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

Mon Sep 09, 2019 8:42 pm

Thank you for taking the time to find out and fix things. Other people might benefit from your work.
edwin/evasive

Do not assume anything

System error, strike any user to continue...
Post Reply