Problems flashing an AMI BIOS...

Questions that don't belong in the other forums.
Post Reply
New visitors - please read the rules.
Posts: 1
Joined: Tue Apr 30, 2002 9:53 am

OK, I have flashed BIOSes before, but I haven't run into this problem before.

Here's the rundown.

Mobo is a PCChips M571 V3.2A with an AMI BIOS from '98. (the original BIOS) It's an older machine (obviously) and I wanted to flash the BIOS to gain large drive support.

So I downloaded the appropriate BIOS (taking into account there are 3 versions for this MOBO, I made sure to double check the mobo rev before downloading it) I also downloaded the flash tool AMINF332.EXE as well.

So I create a boot disk and load the files on it. I boot the system and run the flash utility. (it's a command line utility) I used the comand:

aminf332 990305s.rom

I get back a message of:

>Chipset/Flash part isn't available. The function will be invalid.

Now I've seen talk that this MIGHT be related to the flash utility being too 'new'. I've tried the latest utility and it won't work either. Of course after I tried this flash it killed the BIOS so I had to do a hot swap to get the system running again. (I had an identical BIOS handy)

Any ideas? Anyone have any links to sites that have old versions of the flash utilities handy?


BIOS Newbie
Posts: 18
Joined: Wed Apr 24, 2002 4:01 am

Try uniflash 1.24 or 1.26. It can be found at
Posts: 3153
Joined: Thu Mar 21, 2002 8:16 pm
Location: Near Hannover (CEBIT) Germany

Yesterday I flashed 4 of the well known H.T. chips(MX28F1000PPC) with Aminf332 without any problems in a M571V3.2 .
Check the 5V/12V Flash Voltage jumper - if you have a MX28x or H.T. Flashrom then it has to be set to 12V .
There'is a later Bios existing :
>M5xx > M570_M571
Post Reply