Unable to access bios thru del or Fxx touch

Questions that don't belong in the other forums.
Post Reply
New visitors - please read the rules.
Posts: 4
Joined: Fri Oct 25, 2019 12:56 am

Long story

I got my hands on decomissioned transaction recording modules called MEV in french
They are working but they have been Kinda resetted, id tags removed, meaning no restorant softwares on them, they boot on 4gb CF cards with windows XP embedded.

They are AAEON aec-6822 pdf link: http://data-us.aaeon.com/DOWNLOAD/2007% ... C-6822.pdf
Asked some infos at AAEON, no responses for an original bios.

EDIT : it's an AAEON gene-9455 rev B board in them

First thing i did was to hack/add an admin user and password, since i dont know them ...

Now i have a full windows access ... made some raw backup before playing in them just in case.

Now the fun part

The bios can't be accessed by any mean IE: DEL keypress or any F1 thru F12 key at bootup ?? even disconnected the coin cell 2 days, nothing was resetted / changed.

I'm able to backup / read the bios I can post it on an file hosting

I want to do some bios changes / boot order and i can't do that.

If i swap the CF card between 2 MEV'S they will boot but a constant beep wil be heard, i think there is an signature check somewhere, maybe an dll check, a bios check ... combination ??

On an old install log, i see an given id to the computer.

I know softwares like modbin, cbrom etc ... flash tools etc ...

Is it possible to add the DEL functionality back ??

New visitors - please read the rules.
Posts: 4
Joined: Fri Oct 25, 2019 12:56 am

As a follow up on my Aaeon-6822 computer

Managed to get the AEC-6611 bios, it use the same gene-9455 board, flashed into my board, the computer restart fine, but its missing the lpt port in the bios, the AEC-6611 doesn't have the lpt option, i can live with that.

No AEC-6622 bios seem available from Aaeon because many AEC-6622 are used for sales reports modules (revenu agency), their bios is heavily crippled and they will only boot on th CF card ??? ... you have to find an genuine gene-9455 board, do a bios backup and flash it in the computer, I wont pay 150$ usd for a board ??

After lots of reading

Tried to hack the board info from Aec-6811 to Aec-6822, Modbin6 2.04.03 does the mod, and save the bios, but once flashed the computer will not boot ??? if i re-flash the unmodified Aec-6811 everything is normal again ??

Would be nice to find where are the rs232 ports and the lpt modules are.

With the original crippled AEC-6822 computer backed bios i did an cbrom comparaison, there are 4 missing "group rom" bios modules, and 4 compressed files sizes differences
in xgroup
in acpi
in group rom 0
in setup 0
New visitors - please read the rules.
Posts: 4
Joined: Fri Oct 25, 2019 12:56 am

Last update
I took the AEC-6611 bios (since its based on the same gene-9455 board)

Changed thru modbin the bios message
Finally found out where the lpt option was located, changed to enabled and set to 278 address

And voila ! a working "non crippled" board

Well almost : with physically removed options like the lvds ports/plugs, lvds driver ic, mini pci connector and the sata plug (may try to add this one, i have pcb sata plugs)
The Hardware Archivist
Posts: 6286
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands

Sounds like a fun project. You already thought of uses for these little monsters?

Do not assume anything

System error, strike any user to continue...
New visitors - please read the rules.
Posts: 4
Joined: Fri Oct 25, 2019 12:56 am

lol nope

I wanted to restore it to a normal computer, the lpt port is still not functional, i think the board may have a hardware change / revision, the bios i used AEC-6611 is a version 1.0, if i recall the original AEC-6622 bios is 1.2 or 1.3 ???

But i dont know how i could patch it with the original crippled bios, to correctly get back the lpt port ...

I'll simply re-assemble it and maybe put it on fleabay for a very low price loll

In the mean time i managed to get another kind of embedded computer with more powerful hardware in it, ssd, bluetooth, wi-fi ... more compact and slightly faster 2ghz, and run on a Windows 7, it was used as an led display controller.
Post Reply