new bug found

Only for programmers and BIOS gurus with technical questions.
Post Reply
Master Flasher
Posts: 173
Joined: Sun Mar 31, 2002 2:08 pm
Location: Taka Bonerate National Park, Indonesia

I've found new bug and the solution for uniflash 1.25. Currently the bug as follows:
When I try to flash my bios file <256 Kb> to an atmel flash chip i.e. AT29C020-90, ->uniflash can't recognize the chip <- . Actually this is not the default bios chip of my mobo, I do a hot swapping to backup my mobo bios to this atmel chip. My mobo original bios chip was Winbond W29C020C-90B. My mobo was Iwill VD133 with Via Apollo Pro 693A northbridge and VIA VT596B southridge. Even after trying a couple of times uniflash still didn't work (I've turned off the bios flashing protection in the bios, before doing the hotflash ). Finally I experimented with Award Flash version 7.31 and it worked so smooth, no complain at all, it recognizes the chip correctly and doing the flashing normally. I've also tested the bios, and the computer which uses the atmel chip worked normally.
I've also have the VIA 693A data sheet for smetime. I'll try patch the bug in summer vacation, or if someone have already find the solution, please inform me. My email is:
The UniFlasher
Posts: 3122
Joined: Wed Mar 20, 2002 4:16 pm
Location: Slovakia

Problems with detection of Atmel AT29C010 and AT29C020 chips are known. If UniFlash can detect other chips on your motherboard, this is your problem and you can use -force parameter to force your chip type.
Patched and tested BIOSes are at
UniFlash - Flash anything anywhere
Post Reply