Only for programmers and BIOS gurus with technical questions.
Post Reply
BIOS Rookie
Posts: 56
Joined: Sun Feb 01, 2004 4:48 pm

I Have done some vmware bios mod
more info:
http://www.biosdiy.net/forum_view.asp?f ... ew_id=3533
Borg Number One
Master Flasher
Posts: 169
Joined: Sun May 02, 2004 7:47 pm

I already did it some weeks ago. :)
With latest PhoenixBIOS-Editor-Pro-Version it is no problem. :D

check this too:
http://www.vmware.com/community/thread. ... 439#103439

modify VMware-BIOS in: Phoenix-BIOS-Editor Pro full version

Translated BIOS with user defined Logo

The fullscreen logo is a new one(selfmade) and it is based on exactly the same colors from this logo.

a static screenshot:
BIOS backup - Multi BIOS - prevent a BIOS update failure:
RD1 BIOS Savior

New visitors - please read the rules.
Posts: 4
Joined: Thu Aug 18, 2005 9:44 pm

Can anyone shed a bit more light on how to do this modification. The first link is not in english, and the "borg number one" screenshots (though really nice) don't fully explain how to get it to work.

Here's what I've tried to do so far...
1) take the bios.440.rom from the vmware directory
2) load it into Phoenix Bios Editor Pro
3) Bang my head against the wall as it always says "Incorrect File Size" and crashes.

Also, if I completely remove "bios.440.rom" from the vmware directory it has no effect on vmware. The software still works perfectly. Any ideas?
Borg Number One
Master Flasher
Posts: 169
Joined: Sun May 02, 2004 7:47 pm


The file bios.440.rom does not really seem to be used by VMware.
(Even the staff from the VMware technical support could not explain the sense of the file.)
Furthermore, you are right that the file can be removed without problems.

To modify the VMware BIOS read the article.
(See the link in the previous thread.)

To get the BIOS data / image from the VMware executable you can use a HEX editor to find & extract it manually.

Because of the BIOS BIOS data / image inside the VMware executable is an embedded resource, you can also take resource editors,
such as:
Resource Hacker
PE Explorer
MS Visual Studio


After extracting and modifying the BIOS data you can use/add the
"bios440.filename =" - line in the ".vmx" config file to use the modified BIOS file in VMware.

Threads where I posted stuff/questions about VMware and VMware BIOS modification:
http://www.vmware.com/community/profile ... erID=22880
BIOS backup - Multi BIOS - prevent a BIOS update failure:
RD1 BIOS Savior

New visitors - please read the rules.
Posts: 4
Joined: Thu Aug 18, 2005 9:44 pm

Thanks to the help from "Borg Number One" I was able to pull out the VMWare Phoenix Bios and get it loaded into the BEDemo application. I figured I would recap the steps since the original set was not 100% clear when I was first looking:

1) Open up the vmware executable (/bin/vmware-vmx.exe) using PE Explorer.
2) Go to Resources and extract the embedded resource #6006. I assume this number could change, but the desired resource will be 512Kb in size so it whould be easy enough to find.
3) rename this file to whatever you want, but a good choice is: bios.440.rom. It can then be loaded into BEDemo.
4) BEDemo will create a TEMP directory which contains the uncompressed ROM files. These can be modified and reassembled using: "PREPARE rom.scr" and "CATENATE rom.scr".
5) To get this file to be used by VMWare, you have to first create a virtual workstation.
6) Find the .vmx file for this workstation (mine was in: MyDocuments\My Virtual Machines\blarg.vmx)
7) Edit this file and include the line: bios440.filename = bios.440.rom

That should be it. I did the above and was able to play around with the logo and other files.
New visitors - please read the rules.
Posts: 1
Joined: Sat Aug 04, 2007 12:05 am

HOWTO Modify VMWare BIOS with SLIC 2.1

I wondered how to do this, saw bad files being passed around to be used with bios440.filename, and I answered my own question (in italics) by trying to do this right.

This will take the bois440.rom out, integrate a SLIC2.1 BIN, (optionally bios440.rom can be-reintegrated into ESX/ESXi but Ill pass, and use the VMX parameter file), and activate Windows 2008 R2 in a VM. This allows for 100% unmolested bits in ESX (just a paramter and a file in the VM's dir) and 100% unmolested Windows bits.

I need a hand here. I have ESXi 4.0U1 (b 244038). I would like a Dell ROM for ESX/ESXi 4 that has the Dell SLIC (the rom that you can specify with bios440.filename = fn).

Instead of getting a rom from someone if you could point out the following:

1) How to dump the rom from within a VM.
2) How to modify the ROM dumped to add SLIC 2.1 that will work for Windows 2008 R2 Enterprise Edition.

I think I found out how to do this.

Its better to extract your own bios440.rom file from VMWare as I found the ones being passed around were ancient ((C) 2006)

Things needed:
SLIC ToolKit V3.2 (3.2 latest version as of May 17 10)
http://www.bios.net.cn/Files/soft/biosf ... t_V3.2.rar

I used the HP SLIC route because there is a 2.1 table and certificate available.

(1) First I got ESX BIOS tools (1.0.1 is the latest ver, previous was to extract the bios from ESX(i) 4.0U1

http://forums.mydigitallife.info/archiv ... 12982.html
http://forums.mydigitallife.info/thread ... Bios-Tools
http://rapidshare.com/files/329036460/E ... v1.0.1.rar

This with the service console trivially extracts bios440.rom via SCP.

(2) Add SLIC with this tool
http://slics.myftp.org/Tools/Phoenix_SL ... ool133.zip

http://forums.mydigitallife.info/thread ... EFI-BIOSes

(3) This tool needs a dump of the ACPI tables (DSDT de-compiled)
The Tool to use from within a VM on the ESX(i) is:
RW (aka RW Everything) (v1.4)

This tool, run form within the VM, and click on the ACPI button, it will do some work.

The click on SAVE ALL, or "CTRL+F2" and you have the everything report you need for Phoenix Tool. (report name defaults to AcpiTbls.rw)

I got the latest two certificates from here:

http://forums.mydigitallife.info/thread ... Collection
http://forums.mydigitallife.info/attach ... 1273695934
SLIC 2.1 BINS 5-12-10.7z

I used the BIN and the certificate from here rather than what was with phoenixbiostool133

Anyways, the new bios440.rom was then loaded into esx using the paramter in VMX :

bios440.filename = bios440_HP_SLIC.rom

Where bios440_HP_SLIC.rom was placed into the VMs directory and the parameter was inserted into the VM via the VMX file. Or with Edit Settings, Options, advanced, general, Configuration Parameters while the VM is off.

(4) Loaded up the VM, used SLIC ToolKit V3.2 and the certificate file from SLIC 2.1 BINS 5-12-10.7z (HP's) to verify against the BIN file now integrated in bios440.rom. Works per SLIC toolkit.

(5) Used:
slmgr -ilc <HP certificate name> to load up the certificate for HP into Windows 2008 R2 Ent.
slmgr -ipk <Dell's 2008r2 BKCJJ key>

Dell's Enterprise key worked on the HP BIN in the VMWare bios with HP's cert. Dont worry about not matching that.

Rebooted VM, when booted back up, everything was activated and nominal.

I tried the WGA validation tool and this passed muster.
Post Reply