CD rom drive isn't working

Ask a question about your computer setup.
Post Reply
iamstuck
New visitors - please read the rules.
Posts: 3
Joined: Mon Jun 10, 2002 2:43 am

Mon Jun 10, 2002 2:53 am

hi im new to this forum. Ne ways my, problem is that my E:/ drive icon isn't showing up in my computer. And whenever i put a cd in, my cd-rom driver isn't reading it. my cd-rom drive used to work before. but now it's compeletly useless. i am new to BIOS, all i know is that it has to do something with BIOS. Can u guys solve this problem.
thnx in advance.
NickS
BIOS Bodhisattva
Posts: 3145
Joined: Fri May 03, 2002 10:34 am
Location: Thames Valley, UK

Mon Jun 10, 2002 12:53 pm

Tell us what steps you have taken to establish that it is the BIOS.
What operating system ?
Have you tried with a DOS boot disc with a CD-driver and MSCDEX.EXE ?
Tested patched BIOSes. Untested patched BIOSes.
Emails *will* be ignored unless the subject line starts "Wim's BIOS forum"
iamstuck
New visitors - please read the rules.
Posts: 3
Joined: Mon Jun 10, 2002 2:43 am

Tue Jun 11, 2002 3:07 am

well i went on other forums to help me out figure this out. but there was no help in www.techguy.org. so i found this place and it was all about BIOS. this guy in techguy.org, said that my cd-rom drive wasn't being detected by my BIOS. Then one guy said that to look at my System Properties to see if they are working. My primary and secondery IDE controllers had a yellow exaclamation mark beside. He said that i need to remove it and restart my comp. then my comp will the recognize the new hardware and self install them. but the problem was that it wouldn't let me remove them. It had to do something with "Multi-function Parent thingy"
i have win98 pentium celeron 2, i think my motherboard is MS 6361 but im not sure. i think i screwd up my comp when i tried to make my video card to work better i did things on Properties, but i cant remember what i did.
i don't know anything with MSCDEX.EXE. i dont know what to do in DOS ne ways.
NickS
BIOS Bodhisattva
Posts: 3145
Joined: Fri May 03, 2002 10:34 am
Location: Thames Valley, UK

Tue Jun 11, 2002 10:44 am

You aren't going to like this answer, but it isn't the BIOS and the way I've cured this in the past (under Windows 95) is to reinstall Windows. I've struggled to remove the IDE controller devices or a parent controller and in the end it's always come down to re-installing.
Last month I moved a Windows ME system disc to another box, deleted (I thought) all hardware and re-detected - but it always came back with a problem with on-board sound until I reinstalled. Re-install Windows is my advice.
Tested patched BIOSes. Untested patched BIOSes.
Emails *will* be ignored unless the subject line starts "Wim's BIOS forum"
iamstuck
New visitors - please read the rules.
Posts: 3
Joined: Mon Jun 10, 2002 2:43 am

Sat Jun 22, 2002 3:46 am

but dont u need the cd-rom drive to re-install windows?
Im afraid to do that cause my comp. has no cd-rom rite now.
Can i still reninstall windows98 when i my comp. cant detect my cd-rom drive?
NickS
BIOS Bodhisattva
Posts: 3145
Joined: Fri May 03, 2002 10:34 am
Location: Thames Valley, UK

Mon Jun 24, 2002 2:01 pm

You have to have a boot disc which has the DOS-mode CD-ROM driver on it. Take a look at http://www.bootdisk.com which links to a site with images of boot disks including Windows 95/98/ME. When you run the .exe it will create a bootable diskette with CD-Rom support.
Tested patched BIOSes. Untested patched BIOSes.
Emails *will* be ignored unless the subject line starts "Wim's BIOS forum"
Post Reply