Mod (and backup) DELL GX280 BIOS

Only for programmers and BIOS gurus with technical questions.
Post Reply
New visitors - please read the rules.
Posts: 1
Joined: Sat Aug 08, 2009 10:50 pm

Got a few Dell GX280 desktop computers used as test environment. I use free VMware ESXi server on them to test various pieces of software/OSs.
The annoying part is that ESXi keeps displaying error message that allude to CPUIDLimit is being limited. And recommends to disable this feature in BIOS. However Dell bios has no such settings.

Q1. Is there a way to add this CPUID Limit setting to BIOS?

Here's the latest bios from Dell:
ftp . us . dell . com/bios/GX280A08.EXE

Also these machines support upto 4Gb (4x 1Gb) of RAM (according to DELL), which they are equipped with. However none of the OSs I've tried, including Win XP/Vista 32bit (with and without PAE), XP/Vista x64, Ubuntu 32bit/x64 can see all 4gb. Regardless of what OS tried, they only see 3.1Gb of it. BIOS reports that it sees full 4GB.

After doing some research, Memory Hole (aka memory remap, memory hoist) setting may need to be enabled to let them OS's see the memory above 4gb. However, Dell BIOS once again does not have this option.

Q2. Can memory remapping feature be added via bios hack?

I've tried playing with modbin. However Dell does not provide .bin of their BIOS. I've tried extracting the .rom file from the above exe via
GX280A08.EXE -writeromfile

But modbin can't open it saying it isn't version 6.0.

Q3. Is there a way to back up current GX280 bios? From DOS?
I have tried awdflash but it compains that bios is not right or something like that.

Any suggestions would be most welcome!
The Hardware Archivist
Posts: 6286
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands

Upon booting off the install cd you can press the TAB key to get to a screen to add extra options
The default options looked like

mboot.c32 vmkernel.gz --- binmod.tgz --- ienviron.tgz --- cim.tgz --- oem.tgz --- license.tgz --- install.tgz
What I had to do was to change the about command to look like

mboot.c32 vmkernel.gz nocheckCPUIDlimit --- binmod.tgz --- ienviron.tgz --- cim.tgz --- oem.tgz --- license.tgz --- install.tgz
This allowed the install to continue without checking the COUID limit. After the install finished upon next reboot it will fail to start up because of the same error. I need to press the TAB key again to get to the boot option and add the "nocheckCPUIDlimit" option back one more time.

Once the server started successfully I was able to browse to the server using the VMWARE Infrastructure Client and set the option so it is a permantent option. This is done on the Advanced Tab then click on Advanced Settings. then expand the Kernel otpion in the widnows that pops us and then click on Boot. There will be an option on the right hand side for "VMKernel.Boot.checkCPUIDLimit" Clear the check box and the server should boot correctly the next time.

Do not assume anything

System error, strike any user to continue...
Post Reply