Award boot block bios beep code: video error?

BIOS Questions that don't belong in the other forums. Read them!
BIOS Bodhisattva
Posts: 3145
Joined: Fri May 03, 2002 10:34 am
Location: Thames Valley, UK

The card should be configured for diskette on 3F0-3F7 and IRQ 6. Does the drive seek/step, and does the motor come on ?
Tested patched BIOSes. Untested patched BIOSes.
Emails *will* be ignored unless the subject line starts "Wim's BIOS forum"
BIOS Rookie
Posts: 42
Joined: Thu Jan 15, 2004 11:43 pm

Heh heh, yeah the floppy is being accessed. I've pretty much given up on the bootblock BIOS. It seems other people had the same problem with it and ended up either hot-flashing or replacing the chip. I'll try hot-flashing. If you look at previous posts in this thread, I had the wrong ISA pin when I hot-flashed the first time. Thanks again for all the help!


P.S. Wow, a 2 page thread!
BIOS Rookie
Posts: 42
Joined: Thu Jan 15, 2004 11:43 pm

Wee Hee! I fixed it I fixed it! Many thanks to the forum, and you can read all about the fixing at If you see any mistakes in there feel free to yell at me!

Thanks again to all!

New visitors - please read the rules.
Posts: 1
Joined: Tue Jun 12, 2012 9:51 am

jiteo wrote:Hey forum!

I am back! Some might remember my post "Uniflash: 2 chipsets, 2 chips" in the BIOS Utilities and Flash Programs section. Well I did the hot-flashing, flashed the upper half of the chip, and booted with the newly flashed chip.

Long beep, two short beeps, pause, beep, beep, beep, endlessly. From what the Internet tells me, long beep, two short beeps means video error. The beep, beep, beep, endlessly there seems to be less of a consensus on. Now since I flashed only the boot block correctly, I want to know whether that's a common issue, since the boot block BIOS only supports ISA video cards. I do have and ISA video card in there, but there are some other pins on the card that go into some other slot, so it might not be "pure" ISA. Any ideas?

Its seems that your RAM or memory is not properly inserted.
Mostly beeping error is from memory. try removing your RAM then clean the lower part with an eraser.. Then try inserting your RAM again..
To read more about this try looking here : <shamelss plug deleted>
The Hardware Archivist
Posts: 6286
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands

Already established that it was indeed a corrupt bios, not a memory error. No need to spam your website in here.

Do not assume anything

System error, strike any user to continue...