ASRock 970 extrem4, i killed it help!

Hot-swapping and Boot-Block flash & Boot block flash and floppy support
Post Reply
New visitors - please read the rules.
Posts: 1
Joined: Sat Mar 24, 2012 3:38 pm

here what happened, several days ago i tried to update my bios version on the motherboard through something called UEFI, anyways i restarted my pc during the updateing process, then it didn't boot ever or even "beeb", black screen with nothing on it when i turn on my pc, there is a small screen on the motherboard called Dr.Debug it reads "10", i tried to reset my CMOS by several ways jumper,battary removal and reattach, Clear CMOS button, nothing worked i know iam the reason for this if there is any help please i will appreciate it. i searched on (TweakTown ASRock support) forums and i posted there they said to me remove the battery for 1 day then try again. iam now, any advise els i will try also. ty ^^
The Hardware Archivist
Posts: 6286
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands

check if you are using compatible memory as this error message occurs many times if using incompatible memory.

Do not assume anything

System error, strike any user to continue...
Post Reply