Black screen after disabling Samsung SSD RAPID mode

Hot-swapping and Boot-Block flash & Boot block flash and floppy support
Post Reply
New visitors - please read the rules.
Posts: 1
Joined: Fri Mar 24, 2017 12:49 am

Hello, I hope someone can help me reviving two PC's.

I have a HP Compaq 6300 Pro SFF and 2 HP Compaq 8300 Elite SFF PC's that all worked fine. All have the same BIOS (K01_0304).

In one 8300 I installed a Samsung 850EVO 250GB SSD and did a fresh install of W10Pro, installed Samsung Magician and enabled RAPID mode. Since my PC felt less responsive I disabled RAPID mode and had to restart. The PC booted however I got a hardware error STOP message and my PC rebooted after countdown. Then the screen remained black. After 40 seconds the power fan started to blow loudly. No beeps.

I've tried a BIOS reset, removed the battery for 20 minutes, removed the SSD, tried DisplayPort in stead of internal VGA, replaced memory and swapped power supply to no avail. Without memory I'm getting beeps.

Guessing my PC was broke I then attached the SSD to the 6300. It booted, however I got the same hardware error STOP message and after reboot I got the same problems as with the 8300. It seems like the BIOS of both PC's got corrupted after the reboot following the STOP message. Samsung doesn't offer any help ("Samsung software isn't responsible"), nor does HP ("replace the motherboards" for €300 each) :twisted:

I've tried to recover the BIOS using a USB key with the BIOS file from HP's softpack SP73099 (K01_0299.bin) and SP77888 (K01_0304.bin). It didn't solve the problem. Nor did the Windows+B procedure or a bootable USB with 'DOSFlash.exe /f flshuefi.cpu K01'. Even installing Windows 7 with HP_TOOLS Partition and BIOS file in it on the 8300 that isn't dead and then booting from this HDD in the dead 8300 didn't help.

I came across the boot-block flash method, however my motherboard doesn't have FDD- or ISA connector and my bios.bin is 16MB, so it won't fit on a floppy. Anything else I can try to recover the BIOS?

If not I want to try flashing the BIOS chip using a programmer. However I can't discover the BIOS chip. What is the location of the BIOS chip on the motherboard or how does it look like?
Post Reply