ASRock G41C-GS-R2.0 Cannot Update Bios

Questions that don't belong in the other forums.
Post Reply
New visitors - please read the rules.
Posts: 1
Joined: Fri Feb 15, 2019 12:00 pm

Hello everybody!

I have an ASRock G41C-GS-R2.0 ... cification

Originally the BIOS version was 1.10.

But I flashed the 1.0B version from the manufacturer's site, in order to see if I could get better overclocking capabilities.

I used the Instant Flash application of BIOS and there was no error message.

The mobo works fine but I'm unable to save setting as user default in BIOS (in the OC Tweaker page of BIOS). The 3 default user names (which were something like User 1, User 2 and User 3) are now "_", "a" and another strange character. And nothing happens when you change a name and press enter to save.

Moreover, Asrock OC Tuner (in Windows) gives error "Unable to Load Power Scheme".
And Asrock OC DNA application crushes, giving a memory error code.

Before the update, all the above were working perfectly.

So after all that I tried to flash back the original version of BIOS 1.10 from the mobo site.
But I haven't succeeded so far:

When I use Instant Flash I see the Message "The file was loaded - press any key to reboot"
But, after rebooting, BIOS version is not changed (1.0 Beta i still there).

When I use the Dos Method i get the "Flash Part is not Supported" error.

And I get the same error with windows method.

Any suggestions what to do?
Do you think that 1.0 Beta BIOS installation was successful?

Thank you!
Post Reply