BIOS write protect issue - Awardflash 8.xx

Discusses BIOS flashers and utilities from Award, AMI and Uniflash
Post Reply
New visitors - please read the rules.
Posts: 2
Joined: Tue Nov 17, 2020 10:22 pm

So I recently dug out my old AMD K6-2 350 MHz and decided to give it some love and upgrades. It had been dismantled and the battery pulled a couple years ago, so unfortunately all of my original BIOS/CMOS settings had been cleared. Long story short, I rebuilt the system with the original parts and swapped the HDD with an SD to IDE adapter with a 32 GB SD card. I've seen the same adapter used in a 486 machine that worked wonders, hence why I decided to go this route. Not really seeing any great performance over having an older platter HDD and it has been acting up; crashing, not booting into Windows correctly.

I noticed that the BIOS has an update available on Wim's BIOS site, I tried to flash the bios and got hit with "Flash ROM is Write-Protected. Please make sure whether lockout jumpers is set to correct or not." This was using the DOS based Award Flasher tool. I was using 8.99, the most recent version but perhaps an earlier version might work better? The Winflash version of it is NT/2000 based and upon trying to install Windows 2K on my system, it froze, but I suspect that has to do with the plug & play IRQ stuff. That's a whole different issue.

I thought maybe updating the BIOS would fix some things (or brick the system altogether) but it won't let me do anything, other than backup my current BIOS.

The jumpers that are on the motherboard have nothing to do with the BIOS at all. Mainly voltage, CPU speed multipliers and the like. There's nothing I can find that would give me a way to change a jumper setting for this write protect it speaks of.

System specs with as much info as I can find:
Award Modular BIOS v4.51PG, for Apollo VPG AGP/PCI set
BIOS ID: 10/30/99-VP3-586B-W877-2A5LEPA9C
BIOS chip: WINBOND 29EE011-15
Motherboard: EPoX EP-51 MVP3E-M
Processor: AMD K6-2 3D Now! 350MHZ
RAM: 1 stick of 128 MB SDRAM
OS: Windows 98 SE v4.10.2222
Primary Drive 1: 32gb SD card in SD to IDE adapter
Primary Drive 2: CD-RW drive
Secondary Drive 1: Iomega Zip Drive 100MB IDE
Other hardware installed: 3Dfx Voodoo 3 2000 AGP card, Creative Labs Sound Blaster AWE 64 ISA card, Netgear FA310TX PCI card

Yeah, I know DOSBox can bring all of the retro to life, but the system served me so well in the late 90s and I never had these kinds of problems with it. I really hope it isn't the system's way of telling me that it is on the way out, but if I can fix it up and bring it back to life, I'd really like to. Any help or suggestions would be greatly appreciated.
New visitors - please read the rules.
Posts: 1
Joined: Sat Apr 03, 2021 8:35 pm

Hi ,

same problem with ECS P5VP A+ with same cpu , same bios VP3-586B-W877B
awardflash 8.99 with win 98se boot diskette and same message your rom flash is write protected
no jumper and the bios not show a write bios option ... Perhaps a problem with awardflash..
The BIOS Patcher
Posts: 81
Joined: Mon May 20, 2002 9:20 pm
Location: The Netherlands


Yes, Awardflash 8.xx is definitely the issue here. These newer Awardflash versions can give strange problems on older boards.
For Socket 7 boards you need Awardflash 7.xx. I'm using Awardflash 7.95 and this version works fine here, on any socket 7 board with Award BIOS, except Asus. (For Asus socket 7 use Aflash 2.02).

Cheers, Jan.
Awardflash v7.95
(16.99 KiB) Downloaded 298 times
The Unofficial AMD K6-2+ / K6-III+ page
New visitors - please read the rules.
Posts: 2
Joined: Tue Nov 17, 2020 10:22 pm


Thank you so much! After all the time spent fighting with the newer versions of AwardFlash, I tried the same command line with the 7.95 version you provided and it went through first time without a problem. I downloaded the vp300411.bin and the 7.95, restarted in DOS mode and the system updated like a charm.

If anyone is having the same issue I did, this is the quickest (and most painless) way to update your older BIOS.
Post Reply