DFI WT70-EC not flashing - need advice

Hot-swapping and Boot-Block flash & Boot block flash and floppy support
Post Reply
New visitors - please read the rules.
Posts: 1
Joined: Tue Mar 26, 2024 6:06 am

I've got a DFI WT70-EC motherboard that is stuck in the Award BootBlock and won't take any BIOS bin I try, whether I flash it in AWDFLASH or UNIFLASH. I've tried every available BIOS revision, and keep getting write fails. Newer versions of AWDFLASH (tested V8.99), it states that "Flash ROM is Write-Protected", but this board does not have write protect jumpers. Older versions state "The program file's BIOS-Lock String does not match your system!", which also makes no sense. I've also tried using the /nbl switch which bypasses the error but still leads to write fails. UNIFLASH also fails with a "FLASH DATA VERIFICATION ERROR". Someone else on this forum supposedly had success with re-flashing a backup with AWDFLASH V7.89, but I don't have a backup available for this board, so I can't try it. I also can't flash using a different board as the chip is soldered and I'm fresh out of solder wick.

BIOS chip is SST 49LF004A /3.3V
Post Reply