APM/ACPI BIOS questions
#4390 by MooHoo
Thu Jun 27, 2002 9:30 pm
I've got these errors since I reinstalled windows xp. The only thing that changed since the last time i installed winxp (and it worked ok then) is that now when I installed, I had an updated bios version, one that my motherboard manufacturer (GigaByte) declares that "solves winxp and ACPI problems".

I get random bluescreens and halts, whichafter a few "AMLI: ACPI BIOS is attempting to write to an illegal IO port address..." messages are waiting for me in the event log. I have reinstalled winxp, I tried playing with my bios's configuration (pnp os, acpi, etc...), and nothing helps.

I have a few questions regarding the subject:

1. What are the differences between ACPI and APM? I don't see an APM tab in power management, and I remember having one.
2. If I 'downgrade' my driver to a standard pc, will I have to manually assign irqs? If so, will I be able to make devices share irqs? (I currently have about 16 irqs and over 20 devices using ones.)
3. Can I use a bios version which wasn't made for my mobo? Are there 'GENERIC' bios's?
4. Is there a limited amount of times that I can flash my bios? I think I flashed it over 5 times already, and I wanna know if I can play with it more...

My system specs are:
AMD K-7 650Mhz (Not overclocked)
Gigabyte GA-7IXE, with an american megatrends bios, version FAA (Latest one released by GB)
Sparkle G-force 2 MX400 64mb (Had this problem also with a voodoo 3 3500 card)
Aureal vortex 2 8830 soundcard
Running Windows XP Professional


BTW: Gigabyte's support answered my email after a week, saying that I should try reflashing my bios to the latest version. I already tried that, and it didn't work.


Any ideas?