Memory frequency not recognized on DX48BT2

Is your memory not fully recognized? (Intel VX chipset Memory recognition)
Post Reply
minorking
New visitors - please read the rules.
Posts: 3
Joined: Wed Jan 21, 2009 1:40 am

Wed Jan 21, 2009 1:46 am

I bought this mobo from Intel - DX48BT2 on a Q9450 quad proc. Besides the imposibility for overclocking .. which is not the main subject, this mobo doesn't recognize the real frequency of the memory modules. I installed two modules 2x1GB 1333.. but the BIOS recognize them on auto at 1066. When i force the frequency to 1333 .. the bios calculates it's speed at 1334 .. and after reboot it stalks at a error message from bios.
I know this mobo is not for overclockers but at least i want it to work at full throotle on it's default values.
Denniss
BIOS Guru
Posts: 3153
Joined: Thu Mar 21, 2002 8:16 pm
Location: Near Hannover (CEBIT) Germany
Contact:

Wed Jan 21, 2009 2:16 am

Brand/manufacturer and model of these modules ?
Please verify with CPU-Z (start program and look what's displayed at the SPD section) or similar programs your modules are real DDR3-1333 modules and not just DDR3-1066 "tuned" to run as 1333. Those "tune" are often sold by companies like OCZ.
minorking
New visitors - please read the rules.
Posts: 3
Joined: Wed Jan 21, 2009 1:40 am

Wed Jan 21, 2009 2:54 pm

Corsair CM3X1024-1333C9 (2 modules in dual chanell)
edwin
The Hardware Archivist
Posts: 6215
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

Wed Jan 21, 2009 4:30 pm

I've seen more trouble reported when running these at 1333 on other boards. Will try and find definitive info, you may have to bump the voltage up a bit.
edwin/evasive

Do not assume anything

System error, strike any user to continue...
Denniss
BIOS Guru
Posts: 3153
Joined: Thu Mar 21, 2002 8:16 pm
Location: Near Hannover (CEBIT) Germany
Contact:

Wed Jan 21, 2009 4:57 pm

http://www.corsair.com/_datasheets/TWIN ... 1333C9.pdf

According to the product sheet it's programmed as DDR-1333 with 9-9-9-24 timings at 1.6V. AFAIR this 1.6V standard is violating the JEDEC specifications and may explain the autodetection as 1066.
Please verify the SPD timing programming via CPU-Z. Please also try 1.6V memory supply voltage.
Last edited by Denniss on Wed Jan 21, 2009 9:29 pm, edited 1 time in total.
minorking
New visitors - please read the rules.
Posts: 3
Joined: Wed Jan 21, 2009 1:40 am

Wed Jan 21, 2009 7:28 pm

Setting timings at 9-9-9-24 at 1333 1.62v worked.
Thanks a lot for your time.
And another thing .. all the info I found about my mobo.. a DX48BT2 Intel Bonetrail.. didn't involve a succesful overclock on the CPU. If anybody found anything about overclocking on this mobo, please reply. Thanks a lot again for your help !
Ole
New visitors - please read the rules.
Posts: 1
Joined: Mon Apr 20, 2009 1:59 pm

Mon Apr 20, 2009 2:02 pm

Hey,

Just found this thread while searching for DDR3-1333 pages. Do you have any more details? What range does decent DDR3-1333 run these days, like 2x 1GB or something around that.

- Ole
Post Reply