ROM-O-matic.net , flashrom, gPXE,

Post your suggestions/comments/new info here.
Post Reply
admin
Site Admin
Posts: 755
Joined: Wed Mar 20, 2002 12:14 pm
Location: Belgium
Contact:

Thu Dec 02, 2010 12:50 am

Care to tell us the use-cases for these tools ? :)

Thanks,
Wim
cp
BIOS Guru
Posts: 1914
Joined: Mon Oct 21, 2002 9:07 pm
Location: Germany

Sat Dec 04, 2010 5:40 pm

rom-o-matic generates PXE roms that can be included in almost any bios to allow network boots even from pci add-on cards.

and flashrom is part of the coreboot (former linuxbios) project that allows flashing all kind of chips on different hardware like mainboards, pci-cards, add-in programmers, etc. you can think of it as a supercharged uniflash.
If you email me include [WIMSBIOS] in the subject.
Trevorwin
New visitors - please read the rules.
Posts: 2
Joined: Thu Sep 15, 2011 10:37 am

Thu Sep 15, 2011 10:40 am

I tried creating a ROM to flash my Intel PRO/1000 MT NIC with gPXE a wireless boot but I get stuck at creating a Boot Disk. I configured it on Ubuntu 11. Below are the steps I use/d:
lspci
02:06.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
lspci -n -s 02:06.0
02:06.0 0200: 8086:100e (rev 02)
#etherboot :http://etherboot.org/
<gpxe1user> gpxebot: lspci 8086:100e
<gpxebot> e1000_82540
I downloaded the gpxe src and compiled it. I can create working ISO's with it and can boot wirelessly with an embedded script. I used a CD. Now I want to flash the ROM on my NIC with this script.
cd Downloads/gpxe/src
make bin/8086100e.rom EMBEDDED_IMAGE=wireless.gpxe
wireless.gpxe file contents:
#!gpxe
set net0/ssid MYWIFIAP
set net0/key MYWIFIKEY
autoboot
cp bin/8086100e.rom bin/8086100e.iba
# This is done to refresh with a clean "dosboot.img"
cp /home/myfolder/Downloads/dosboot.img .
mcopy -i dosboot.img bin/8086100e.iba ::
# IBAUtil.exe was automatically extracted when I downloaded PROBOOT.exe
mcopy -i dosboot.img /home/myfolder/Downloads/APPS_intel/IBAUtil.exe ::
For USB stick, do this:
sudo dd if=dosboot.img of=/dev/sdc1
USB stick contents:
8086100e.iba
AUTOEXEC.BAT (0 bytes)
COMMAND.COM
CONFIG.SYS (0 bytes)
IBAUtil.exe
KERNEL.SYS
For CD, do this, then burn ISO:
mkisofs -b dosboot.img -o dosboot.iso dosboot.img
CD contents after burning the ISO:
boot.cat
dosboot.img
Neither USB stick nor CD work when booting. The screen is just black with a blinking underscore. I've tried them both on several machines. What can I do to get around this?
Thanks
Post Reply