75GB: 08/12/96-i430VX,UMC8669-2A59GL1CC-00

BIOS update, EIDE card, or overlay software? (FAQ Hard disk recognition)
dazzin
New visitors - please read the rules.
Posts: 11
Joined: Sun May 04, 2003 2:43 pm

My old Pentium 133 recognize it as a 8GB disk..
Everything goes well except that the size is incorrect... :)
What can i do?

The HDD is a IBM DTLA-307075 (75GB).

BIOS Type: Award Modular BIOS v4.51PG
BIOS ID: 08/12/96-i430VX,UMC8669-2A59GL1CC-00
BIOS Eval: P54CE REV.F RELEASE 8/12/1996 BIOS VER.F06 UM8669

Regards. //Daniel
from sweden...
ajzchips
El cheapo dude
Posts: 3048
Joined: Sat Mar 23, 2002 12:41 pm
Location: Madrid, Spain

I patched a BETA BIOS several months ago for that board (never received any feedback), which you may want to try. It should support HDDs upto 128GB.

http://wims.rainbow-software.org/ajz/

Luckystar P54CE Rev.F BIOS.
dazzin
New visitors - please read the rules.
Posts: 11
Joined: Sun May 04, 2003 2:43 pm

Ofcourse i will test it! :)

But tomorrow night, i´m about to go to sleep soon :)

Is it possible to make a backup of my present bios?
from sweden...
ajzchips
El cheapo dude
Posts: 3048
Joined: Sat Mar 23, 2002 12:41 pm
Location: Madrid, Spain

Sure. Since you'll be using an Award flasher (preferably versions 5.x), find out the syntax by executing "AWDFLASH /?" first.
dazzin
New visitors - please read the rules.
Posts: 11
Joined: Sun May 04, 2003 2:43 pm

It didn´t work.. :( It still "thinks" it´s a 8445MB (or something like that) in the bios setup. :cry:

BIOS Type: Award Modular BIOS v4.51PG
BIOS ID: 12/23/1998-i430VX,UMC866-2A59GL1CC-00
BIOS Eval: (2a59gl1c) EVALUATION ROM - NOT FOR SALE


but i think i used award flash v6.0.. cause i dint find any in the 5.X series :(


Hope u can help me, have i done something wrong?
from sweden...
ajzchips
El cheapo dude
Posts: 3048
Joined: Sat Mar 23, 2002 12:41 pm
Location: Madrid, Spain

Doesn't matter. If it flashed correctly, then you're safe.

a) Is it AUTO-recognized as an 8GB drive, or did the CMOS store the previous (if any) manually-entered settings for the old BIOS?

b) Have you tried to manually enter the drive's parameters?

c) Even if autodetected as an 8GB, there's still hope. Wait and see what FDISK tells you (download the latest version from MS' site).
dazzin
New visitors - please read the rules.
Posts: 11
Joined: Sun May 04, 2003 2:43 pm

I had choosen User ----- AUTO...

so i switched to AUTO ------


when i´m booting from the floppy drive.. i see (when it has come to the screen after bios)

bla bla bla
|------------------------|
|LBA, mode 4, 76GB, |

Verefying bla bla pool data


If you know what i mean? :oops:

BUT fdisk recognize it as a 8GB HDD, so i think my solution is to get a newer version of fdisk, but it seems hard to find one @ Microsoft.com

Your bios mod seems to work, and i´m very pleased with it so far! Good Work!

Now i just got 1 tiny problem left i think :) Fdisk ;)

Thanks again!
from sweden...
Denniss
BIOS Guru
Posts: 3153
Joined: Thu Mar 21, 2002 8:16 pm
Location: Near Hannover (CEBIT) Germany
Contact:

If it's still the DOS 6.22 FDISK then you'll need a new OS supporting big size HDD
With Win95B/C more than 32GB might be supported but for sure with Win98 and higher
dazzin
New visitors - please read the rules.
Posts: 11
Joined: Sun May 04, 2003 2:43 pm

hmm ok i used the "xpboot.exe"

But now i have tried with a program for WD HDD´s.. and it formated and partitioned my drive... so when i boot up with a bootdisc now, i got 73GB avaible space :D

but is there any other program who is little more universal??
from sweden...
ajzchips
El cheapo dude
Posts: 3048
Joined: Sat Mar 23, 2002 12:41 pm
Location: Madrid, Spain

Try the WinME bootdisk from www.bootdisk.com , if you're going to use FAT32, of course.
dazzin
New visitors - please read the rules.
Posts: 11
Joined: Sun May 04, 2003 2:43 pm

Hmm strange... now it thinks i got a 33688MB disk (that text over Verifying DMI pool data....)


And the partition and format program by western digital wasn´t that good, it seems like it has modified some files at the bootdisk and put them in the root at the IBM HDD, so when i start my computer without the bootdisk, i get a meny called "EZ-BIOS" And it ask me if i want to install an OS, if so i have to put a diskette in the floppy, or if i want to go to dos prompt instead.



About the Win Me Bootdisk, it didnt work for me (tested 2 different versions.. ) both of them hang during the "Verifying DMI pool data..." screen .

I hope u understand my crapy english :wink:

Any good advices??

Maybe i should clear cmos and reflash my bios and test the WinME diskette again?
from sweden...
Rainbow
The UniFlasher
Posts: 3122
Joined: Wed Mar 20, 2002 4:16 pm
Location: Slovakia
Contact:

If you boot from Windows ME floppy (with no EZ-BIOS installed), run FDISK from there and see 8.4GB only, then the BIOS does NOT support HDDs over 8.4GB. It's not uncommon for these i430FX/430VX BETA BIOSes...
Patched and tested BIOSes are at http://wims.rainbow-software.org
UniFlash - Flash anything anywhere
dazzin
New visitors - please read the rules.
Posts: 11
Joined: Sun May 04, 2003 2:43 pm

That was not funny to hear :(

Is it possible to modify it? Is it hard to modify it? Maybe you guys could do something?
from sweden...
edwin
The Hardware Archivist
Posts: 6275
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

This one can be patched.

Patched bios sent.
edwin/evasive

Do not assume anything

System error, strike any user to continue...
dazzin
New visitors - please read the rules.
Posts: 11
Joined: Sun May 04, 2003 2:43 pm

It didnt work..

With 98 bootdisk fdisk says 8033MB´s..
With ME bootdisk computer hangs during "verifying DMA POOL data..."

The screen over "Verifying dmi pool data" says "LBA, MODE 4, 33822MB"

Bios settings set to AUTO


:cry:
from sweden...
Post Reply