80GB: 05/07/1998-i440BX-W83977-P6BX-A+ XP Setup problem

BIOS update, EIDE card, or overlay software? (FAQ Hard disk recognition)
Post Reply
New visitors - please read the rules.
Posts: 2
Joined: Tue Jan 03, 2006 10:14 pm

I have an old P2 450 that originally had a 4GB WD drive in it. I bought a 80GB Seagate Barracuda and tried to install it but the BIOS HDD autodetect was hangning so I needed a BIOS update. My original BIOS info was:

Computer ID : FC, Type : AT
BIOS Date : 05/07/98
Award BIOS found : Award Modular BIOS v4.51PG
Award ID-String : 05/07/1998-i440BX-W83977-P6BX-A+
Board/BIOS-Version : P6BX-A+ Ver 2.4 05/07/1998

Based on what I learned from this site, I successfully downloaded and flashed the BIOS with the patched version "P6BX-A+ Ver 2.4 05/07/1998 patched for 128GB HDD" (downloaded from this site). With the old drive in the machine, it continued to work fine ie. the BIOS update didn't break anything.

It was when i replaced the old drive with the new one that things got weird. I set the jumpers on the new drive to primary master and installed it, but the BIOS HDD Autodetect still returns that there is no primary master drive (or in fact any drives at all).

HOWEVER, if I boot from the Win XP install CD, it DOES detect the drive and I am able to successfully complete the first part of the install ie. XP Setup detects the drive, allows me to create and format a ~76GB partition and copy across the initial XP installation files from the CD.

The problem is when the XP install gets to the 'Your computer will reboot in 15 seconds' part. When the machine reboots, the BIOS still cannot detect the drive (see above) and so boots to the CD again, causing the install to start again from the beginning. Note that I have made sure the boot sequence in the BIOS is "C, CD-ROM, A"

I have googled all morning on this but no luck. Has anyone seen this before and/or know what I am doing wrong?

Thanks heaps in advance
Posts: 3153
Joined: Thu Mar 21, 2002 8:16 pm
Location: Near Hannover (CEBIT) Germany

Check HDD manual, maybe your HDD should be set to Single-Master or Cable-Selcet instead of Master. If you are using an 80-wire IDE cable then connect the bluen end to mainboard and black end to HDD.
New visitors - please read the rules.
Posts: 2
Joined: Tue Jan 03, 2006 10:14 pm

Hi Denniss,
Thanks heaps for your post. I have standard 40 wire cables with black plugs at both ends, so from what I understood, Cable Select should not have worked. However, in desperation I tried it anyway and it does!! The HDD detect in the BIOS now detetcs the drive and presents me with 3 different combinations of heads/blocks/sector etc sizes to choose from. I have found that if I choose the one with 255 heads then it now boots and the XP setup process continues.
So, I am now back in busines and you officially rock!
Thanks dude
Posts: 761
Joined: Wed Oct 30, 2002 5:17 am

Glad you got it sorted out with some help from Denniss.

I was going to suggest it would probably be worth using the 80 Wire ATA 100 cable, but given the apparent age of the board the system would probably not take advantage of it.

When you run IDE auto detection in older AWARD BIOSs, you often get presented with three options, and the one marked Y is often the correct one to choose, which can be done by using the Y key instead of it's number. However since you have everything running nicely on the current configuration it is probably best to leave as is until next time you have a good reason to redetect the drive.
New visitors - please read the rules.
Posts: 4
Joined: Mon Jun 27, 2005 4:11 pm

I always leave the BIOS hard drive settings at "AUTO". I never use the autodetect utility in the BIOS.

Not sure about the BIOS you used but I just flashed my ECS P6BX-A+ rev 2.1 motherboard last night with the official version 5.6 bios to support large drives. You can get it on this page...


I used the Uniflash utility because I don't trust motherboard manufacturers to post the correct version of the flash utility on their sites. You can get the latest version of Uniflash from here...

Post Reply