My video card does not work.

Video, SCSI, modem, CDROM/CDR/CDRW, etc.
Post Reply
baryamin
New visitors - please read the rules.
Posts: 3
Joined: Thu Aug 28, 2003 6:02 pm

I have a Creative Labs CT6980 video card 16MB.
I just installed windows 2000 and on installation windows recognized it as tnt NVIDIA and installed that driver. Anyway the video card does not function properly. I tried to uninstall the card and install a different driver (creative, NVIDIA.. ) but nothing seems to work.
I have an award bios PT-6IBD/H 07/08. Can anyone help me with this one.
Thanks.
soupy
Absentee administrator
Posts: 1086
Joined: Thu Mar 21, 2002 1:06 am
Location: Ontario, Canada
Contact:

How do you mean it doesn't function properly?
Flash your BIOS at your own risk.
baryamin
New visitors - please read the rules.
Posts: 3
Joined: Thu Aug 28, 2003 6:02 pm

In the windows device manager , there is a Question mark (?) near the video card driver and it says that it is not working properly.
I added the bios comments since I wanted to know if this issue is bios, OS or driver related .
edwin
The Hardware Archivist
Posts: 6273
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

The CT6980 is not listed at Creative, I suspect this is an OEM variant (Compaq? ), but you can use the CT6981 drivers:
http://www.americas.creative.com/suppor ... 9&subcat=1
edwin/evasive

Do not assume anything

System error, strike any user to continue...
baryamin
New visitors - please read the rules.
Posts: 3
Joined: Thu Aug 28, 2003 6:02 pm

I am starting to suspect that this driver/video card was not designed for windows 200 but win 98/se. I found a driver for the 6890 but it was only for win 98 and non of the win2k dirvers work. Maybe you guys have another suggestion?
Post Reply