BIOS settings for CD-ROM to work properly again!

Ask a question about your computer setup.
Post Reply
Robnorth
New visitors - please read the rules.
Posts: 2
Joined: Sun Jun 02, 2002 4:05 am

Sun Jun 02, 2002 4:15 am

I have a Tyan S1571 motherboard using the TX chipset and Award BIOS 4.50PG.

Having read about it elsewhere, I took the opportunity to remove the Pentium 200 MMX CPU and replace it with a K6-2 400 CPU.

As part of doing this, I (a) flashed the BIOS with a newer patched version which allowed the motherboard to work properly with the K6 (see http://www.exit109.com/~scotth/1571/ ), and (b) then reset the CMOS as directed by the flash procedure.

(I have a 3.25G hard drive as C: with Windows 98SE, as IDE primary master, and a 6G hard drive as D: as secondary master; both are Maxtor drives. I have a 4/8G tape drive -- Seagate STT8000A -- as primary slave, and an older Compaq CR-587 CD-ROM as secondary slave.)

Since then, my CD-ROM has been acting strangely. If I insert a game CD (something like a simple Boggle from Hasbro), the autodetect works fine, although a little slower than usual; I can then play or install the game with no problems.

However, most other CD's -- including my Windows 98 SE CD-ROM -- aren't recognised. For example, I've also pooched my LPT driver. I try to reinstall the driver, it asks me to insert the W98SE CD-ROM. I do so, but it reacts exactly as if I hadn't closed the drive, or if I'd closed it with no disc inside. When I try to use DOS to look at the files (dir E: ), it says 'Drive not ready'. (Funnily, with a game CD such as the Boggle one mentioned above, I *can* read the directory from DOS.)

I'm guessing that in resetting the BIOS settings (by erasing the CMOS), I've set something wrong so that the system can't see the CD-ROM properly. I've tried changing 'PnP OS Installed?', 'Resources Controlled By', 'PCI IDE IRQ Map To:', but no luck.

Any ideas? :cry:

Thanks!!

Robert
Hardware Junkie
Mobo-Fu Master
Posts: 119
Joined: Mon May 13, 2002 11:20 pm
Location: Ottawa, Ontario, Canada
Contact:

Sun Jun 02, 2002 4:32 am

Interesting. I would check hardware related problems, or operating system issues before I would blame a BIOS update.

Easy way to figure out if its a hardware problem VS a software problem would be to try and boot from your OS CD. Place it in the drive and change the Boot order in the BIOS to boot from CDROM.
If it works, then your looking at an operating system problem. Try reinstalling Windows.
If not then try replacing the cables, very cheap to do so. See if that fixes it. If you have another cdrom drive to test with, see if that works.

Very slim chance that the drive is no longer compatible, but it is possible.
"Imagination is the only weapon in the war against reality." -Jules de Gautier
Robnorth
New visitors - please read the rules.
Posts: 2
Joined: Sun Jun 02, 2002 4:05 am

Sun Jun 02, 2002 5:42 am

It never booted from the CDROM before. Before I did this change, while the CDROM was working fine, I had tried changing the BIOS boot ROM order to include CDROM (or even put it first). I don't think it ever recognised the CDROM as such, and never booted from it; I always had to use a boot floppy. So I don't think that's going to help me much.

I'm pretty sure I screwed up the PnP/IDE settings somehow. Of course, I wasn't smart enough to take careful note of all the settings before I reset the CMOS.... :?

Robert
Rainbow
The UniFlasher
Posts: 3122
Joined: Wed Mar 20, 2002 4:16 pm
Location: Slovakia
Contact:

Sun Jun 02, 2002 10:32 am

Try the CD-ROM drive in another board/computer. If it does not work too then it's CD-ROM problem (such as dirty laser lens).
Patched and tested BIOSes are at http://wims.rainbow-software.org
UniFlash - Flash anything anywhere
Post Reply