Asus TX97-E ACPI BIOS with HDD patch needed

BIOS update, EIDE card, or overlay software? (FAQ Hard disk recognition)
Post Reply
gold007
New visitors - please read the rules.
Posts: 15
Joined: Sun Oct 16, 2011 6:58 pm

Asus TX97-E ACPI BIOS with HDD patch needed

Post by gold007 » Sat Nov 16, 2013 8:20 pm

Hi guys,

I'd like to update the BIOS of my Asus TX97-E board to support bigger HDDs, but I need ACPI support. Could someone please make me a patched version of that?

Thanks
Gold007

edwin
The Hardware Archivist
Posts: 6206
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by edwin » Mon Nov 18, 2013 8:35 pm

If you can provide us with the 1001e_03 ACPI BETA bios for this board since Asus pulled it off its servers due to windows 2000 problems at the time. the 0112e with the same date stamp that is around has no ACPI support.
edwin/evasive

Do not assume anything

System error, strike any user to continue...

gold007
New visitors - please read the rules.
Posts: 15
Joined: Sun Oct 16, 2011 6:58 pm

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by gold007 » Tue Nov 19, 2013 8:19 pm

edwin wrote:If you can provide us with the 1001e_03 ACPI BETA bios for this board since Asus pulled it off its servers due to windows 2000 problems at the time. the 0112e with the same date stamp that is around has no ACPI support.
Thats the other problem, I can't find it :( I was hoping that some of you still have it since you are making a lot of bios patches. I have the patched version of 0112e, but, yes, it doesn't support ACPI, so it doesn't matter what version if there is no ACPI :/

edwin
The Hardware Archivist
Posts: 6206
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by edwin » Wed Nov 20, 2013 10:25 am

I'd have to bring my old storage server online and see if I managed to mirror the asus FTP site at the right time...
edwin/evasive

Do not assume anything

System error, strike any user to continue...

gold007
New visitors - please read the rules.
Posts: 15
Joined: Sun Oct 16, 2011 6:58 pm

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by gold007 » Sun Nov 24, 2013 4:48 pm

That would be great, but I tried to flash another version, and It doesn't work. I mean the board is working perfectly, but uniflash can't detect the chip, and awdflash restarts the computer after a few seconds. The bootblock jumper is in enabled position. I also tried shorting the VCC to 5V, and VPP to 12V, but it still didn't work...

edwin
The Hardware Archivist
Posts: 6206
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by edwin » Mon Nov 25, 2013 10:08 am

Is this a retail board or one from a branded system (Packard Bell, VOBIS, Sony, HP, Compaq...)?
edwin/evasive

Do not assume anything

System error, strike any user to continue...

gold007
New visitors - please read the rules.
Posts: 15
Joined: Sun Oct 16, 2011 6:58 pm

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by gold007 » Mon Nov 25, 2013 10:30 pm

It's an original Asus TX97-E motherboard as stated in the thread title. It's rev. 1.11, and it's working fine except this bios update issue. I have a Pentium 120mhz cpu in it.

Denniss
BIOS Guru
Posts: 3153
Joined: Thu Mar 21, 2002 8:16 pm
Location: Near Hannover (CEBIT) Germany
Contact:

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by Denniss » Tue Nov 26, 2013 2:53 am

For this old board series you need the Asus Flasher Aflash.
Attachments
aflash221.zip
(57.6 KiB) Downloaded 160 times
Tx97-e.zip
(1.05 MiB) Downloaded 168 times

edwin
The Hardware Archivist
Posts: 6206
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by edwin » Tue Nov 26, 2013 10:00 am

ah the 1001e_003 bios is in there. I have to check if it's already patched for large disks then.
edwin/evasive

Do not assume anything

System error, strike any user to continue...

gold007
New visitors - please read the rules.
Posts: 15
Joined: Sun Oct 16, 2011 6:58 pm

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by gold007 » Tue Nov 26, 2013 9:25 pm

Denniss wrote:For this old board series you need the Asus Flasher Aflash.
Thanks for the aflash program! I've been searching for it. But I tried it and it still doesn't work. It says "Error -- Flash memory unknown" so it's the same, the chip is not being detected :evil: And one question: is this bios file the patched, or the original one, which you attached?

Denniss
BIOS Guru
Posts: 3153
Joined: Thu Mar 21, 2002 8:16 pm
Location: Near Hannover (CEBIT) Germany
Contact:

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by Denniss » Tue Nov 26, 2013 10:55 pm

I'll look for an older Aflash version, please also look for a write protection setting in Bios.
I assume the file in the attached .zip is not modified to support larger HDD but Edwin is looking into it.

What type of flashrom do you have?
Winbond/SST/Atmel or MXIC were common manufacturers in these days + the chip number is also required.
Hint: 28xx part number is 12V, 29xx is 5V

gold007
New visitors - please read the rules.
Posts: 15
Joined: Sun Oct 16, 2011 6:58 pm

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by gold007 » Thu Nov 28, 2013 10:42 pm

I have atmel at29c010a on the board. The jumper on the board is in the write enable position, but in the BIOS I can't find any options regarding this :(

edwin
The Hardware Archivist
Posts: 6206
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by edwin » Fri Nov 29, 2013 5:50 pm

what chip does uniflash report?
edwin/evasive

Do not assume anything

System error, strike any user to continue...

gold007
New visitors - please read the rules.
Posts: 15
Joined: Sun Oct 16, 2011 6:58 pm

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by gold007 » Fri Nov 29, 2013 8:38 pm

edwin wrote:what chip does uniflash report?
Nothing, that's the problem. It says: flash rom chip: unknown; organisation: N/A (write protect blabla...); chipset: triton III 430tx; last write status: not available

Denniss
BIOS Guru
Posts: 3153
Joined: Thu Mar 21, 2002 8:16 pm
Location: Near Hannover (CEBIT) Germany
Contact:

Re: Asus TX97-E ACPI BIOS with HDD patch needed

Post by Denniss » Fri Nov 29, 2013 11:15 pm

Either a hardware problem, a missed setting in Bios or the write protect jumper in wrong position (check for an onboard printing of the jumper setting, sometimes manual is wrong or it was changed in a motherboard revision).

Aflash 1.37:
http://dlcdnet.asus.com/pub/ASUS/mb/slo ... aflash.exe

Post Reply