Boot Block BIOS flash doesn't work

Hot-swapping and Boot-Block flash & Boot block flash and floppy support
Posts: 761
Joined: Wed Oct 30, 2002 5:17 am

When you say you did not get UniFlash to work, did this mean you were trying to boot to it from CONFIG.SYS or AUTOEXEC.BAT?

Just that it sounds like were having trouble trying to get anything to work and once you got to a command prompt you went for the AWDFLASH. I only suspect that once you were at a command prompt that UNIFLASH would have worked just as well at that point as AWDFLASH.

Be interesting to hear from anyone who has good reason to think differently.
Chip off the ol' block
Posts: 110
Joined: Wed Mar 30, 2005 7:11 pm

Ritchie wrote: Be interesting to hear from anyone who has good reason to think differently.
10 posts up from yours states this post below, how he claims that
uniflash didn't detect the flash rom, might be what he means..
Japraiser wrote:same here. Many Thanks for this piece of software:)... it really helped me out. The only problem i had to deal with now was that uniflash did not recognise my a7n8x-e deluxe flash chip. But when i inserted a floppy with awdflash (the real awdflash) in dos it worked perfectly well.
Although funny enough when I myself have had uniflash not detect a
flash rom, I'd find another similar rom mounted board with a different
chipset & use uniflash to do a hotflash...
Iv'e had cases in the past where uniflash wouldn't detect a flash rom
that I knew it had previously detected & flashed to on boards that had
different chipsets, it seems it's fussy with boards running certain
combinations of flash roms on particular chipsets, even when iv'e
checked to see if perhaps the chip was write protected via jumper.
Been a while now so not sure what the combination was, I bought a
burner 2 years ago now, never needed to hotflash since...
New visitors - please read the rules.
Posts: 1
Joined: Thu Jul 19, 2007 4:28 am


I loved the awdblock utility so much, I registered on Wim's BIOS just to let you guys know what a wonderful forum this is.

I had the same problem: A7N8X Deluxe (no less) goes kaput when trying to flash with ASUS's own awdflash program. Ho hum, I thought, but Asus's support takes _forever_. I'm still waiting for a call from them. And to think that they're in the Bay Area as well! Sigh.

Anyway, long story short, I had the same problem: BootBlock 1.0 was trying to load awdflash.exe, and passing some parameter which is the name of the .bin file. Almost impossible to tell what is going on. So I created DRDOS boot disks (from and copied dos freak's awdblock utility. Dropped me to a command prompt. I flashed my bios with awdflash (version 2.3f) and with BIOS version 1008 (not 1009, that is beta for my motherboard).

Now my machine is back up, and I'm booted into Linux. Yay for me.

(If anyone needs my awdflash or bios boot rom, I'll put them up on my website soon. I'll post again after I do this.)

Thanks again, guys! You saved me time, hassle, money, and many strands of scalp hair.

And I learnt a *lot* in the process, so I'm indebted.
New visitors - please read the rules.
Posts: 11
Joined: Mon Jan 20, 2014 6:26 pm

dos-freak wrote:
Wed Sep 17, 2003 4:56 am
Once again, I seemed to have solved the problem myself.
I wrote a little loader, which executes the code in the boot-sector of a Floppy, so that I'm able to load MS-DOS, even when only the boot block BIOS works.
I checked how it works in Qemu with an MS-DOS 6.22 floppy image:

Code: Select all

qemu-system-i386 -bios BIW2M130.BIN -fda awdbb.vfd
Bios: ...
Qemu: ... 131128.exe

P.S. In newer versions of Qemu with the bios BIW2M130.BIN floppy emulation does not work.
Post Reply