#19612 by dos-freak
Tue Sep 16, 2003 4:45 am
Hi!

I tried to flash my Chaintech 7AIA5 - Board toaday with the newser BIOS - Version from
http://www.chaintech.com.tw:8008/AP/BIO ... odel=7AIA5

I started the AWDFLASH-Utility via ALT+F2 and inserted a floppy with the new BIOS-file. The utility immediately started to work and in the middle of flashing, it died, because of a read-error on the floppy (i later tested the floppy and there were unreadable blocks where the new bios-file was).
So The system rebooted using the boot-block bios.
It prompts me for a floppy with AWDFLASH.EXE on it (yes, it displays something even with my AGP-Graphics card!). So I downloaded the AWDFLASH-utility from Chaintech, which was suitable for my board and put it on the floppy.
After reading the new BIOS files from the disk, it says: "The Program file's BIOS Lock string doesn't match with your system!"
So I looked in the internet for a solution for this problem and found out, that I had to use the /nbl parameter.
But how can I tell the boot-block BIOS the parameters I want to pass to the awdflash-program?
I read, that I would only have to create an AUTOEXEC.BAT with "awdflash.exe <filename> /options " in it. So I did this but the boot Block BIOS seems to ignore it.
So I tried with older AWDflash-versions. They say "System was not NEW AWARD BIOS Version. Please updata ROM BIOS first ...."
I tried to put other flash utilities on the disk and name it AWDFLASH.EXE, but they don't execure correctly (I think, they are using DOS function calls which are of course not available).
I also tried to put a file with the DOS boot-sector on the disk and name it AWDFLASH.EXE and also copy all the other DOS system-files onto it.. no Luck.
So I'm now really desperate. What would be a Solution to the Problem?
Should I try to disassemble AWDFLASH and bypass the Error-Checking Routine? This would be quite hard for me and if possible, I want to avoid this work.
I hope, someone can help me.

Thanks in advance!