Don't ask how to hack password. (BIOS Passwords)
#46443 by paradigm
Tue Oct 23, 2007 11:28 pm
yep..... guys another fatality


this is the (in)famous 4104WLMI...or rather from the same family of the 4100 series which is built by ACER and sent to 2 continents by different model nos (the 1640/Z and here in Asia incl EU)...and posts their bios in one folder with barely a noticable digit diference
it has taken me some time getting to this website after going through ton's of usless websites

i had posted in the thread

http://www.wimsbios.com/phpBB2/topic8541.html

and have gone through the search regarding every thread with the word ACER in it..... as a last resort i am posting a new thread, since it has not been updated in a while, and i was unable to post any further (due to a site error)

thing is

the solution in this thread worked.....kinda

welll atleast the first time, i made a flashable USB drive (as a HDD cuz the floppy image did not have enough space to keep the bios as well..used a file *.img dos622....)..posted by tolik

I all!

After 5 days of researching the internet forums and others, I have found the solution for my laptop ACER Aspire 1640z.

1. Make USB flash boot disk
2. add to the usb disk the original bios file and copyes of the bios with diferent ex. like bios.bak, bios.wph, bios.rom and executable files autoexec.bat and fix.bat with string "PHLASH16 /mode=3 /x bios.WPH" and the patcher phlash16
3. unplug the battery
4. unplug the ac/dc cable
5. plug the USB disk
6. hold keys [Fn]+[Esc] (or [Crtl]+[Esc] opt.)
7. during holding the keys plug the ac/dc cable
8. press the power button on laptop
9. release the keys [Fn]+[Esc] (or [Crtl]+[Esc] opt.)
after short time press one more time [Fn]+[Esc] (or [Crtl]+[Esc] opt.)

I have sucseed after 5 try.


so this started up the ACER as indicated in the tutorial...the PC went through some beeps (error codes 2 short one long), started reading the USB flash drive, and then restarted a couple of times....all this i was not depressing the ctrl+esc (this worked, the Fn=esc..just gave the error beeps and nothing else) ...thing is i got that grey boot up of the screen...no image...just the grey...like a back-light...then the PC went into an auto cycle of rebooting and reading and restarting without showing a logo or anything.....went on for a minute
when..i finally shut it down
i am now back to the dark (no power to LCD mode) can you guys help me any further.....i am trying to get a USB floppy drive but i cannot find it in my city

now that i got my floppy TODAY.....i tried to get this amazing CRISIS prog. but unfortunately this site DOES NOT OPEN

http://www.rechner.org/b1800.html

so can someone please mail it, upload it, anywhere...the methods to flash this baby back to life are pretty well written here (wim's bios)....so following the instructions has been easy...and for the 1st time in almost a month i got to see some power up from the laptop so i have hope...please guys i need your help restoring this

thirdly amongst the steps i have seen (including what acer recommends in DOS based flashing the scripts differ by just a little....could this be the reason why i cannot blind flash the system

Tolik's method for the blind flash requires a autoexec.bat be made using a notepad/text doc. to be saved as *.bat, having a script

PHLASH16 /mode=3 /x bios.WPH (has been copied from his post directly...as it is to make a *.bat file)

the ACER ppl say

To flash in pure DOS mode, pls run: PHLASH16 xxx.WPH /mode=3 /S
P.s.
If you're using DOS bootable floppy (w/o himen.sys) created in Windows XP,
you will get an error like "can't present memory manager" while you
update the BIOS (ie himen.sys)

You may do either one of the two ways to resolve:
1. press F5 to bypass himem.sys
2. modify the parameter from /S to /X

The parameter /X for PHLASH is "Ignore XMS memory manager check".
The parameter /S PHLASH is "Silent operation (Turn off speaker)".

can you ppl...anyone have the exact same crisis file that was to be found at http://www.rechner.org/b1800.html...please give it to me with any additional steps i might need to make...i have the floppy drive for another 12 hours (sorta paying rent)

i really would like this pc to boot...it is not mine, but my parents bought it for my younger sister, to use during her study periods in london..... now due to a mistaken bios flash (yep the same confusion for the 1640-4100 series) i am stuck with this dead lappie