Don't ask how to hack password. (BIOS Passwords)
#48852 by Anabolic
Wed Apr 09, 2008 1:43 am
Hi there,

I have recently downgraded my ACER 4315 notebook from Vista to XP and in the process of trying to get drivers to install for the notebook i downgraded my BIOS version from v1.08 to v1.04. At the time i found some postings on the net that said this may help install the drivers i was having trouble with.... This was not the case and i found them elswhere.

The trouble i am having now is that when the notebook powers up without the AC Power connected it gives me "Warning! Incorrect battery used! Using incorrect battery can cause system damage. Please remove the battery and insert the correct one. The system will shut down in a few seconds." The notebook is brand new and the battery is one supplied with it in the box.

If the AC Power is connected it starts and gets passed this error msg. I have tried to re flash the bios with v1.08 from "http://support.acer-euro.com/drivers/notebook/as_4315.html" and installing it.

However the WFlash program gives me a "Power Check Error" and will not let me proceed.

Could someone please advise me on how to go about fixing this problem?

I have tried taking the battery out and running it only on AC Power but i still get the same error when running the WFlash program.

Thank you in advance.
Anabolic