Don't ask how to hack password. (BIOS Passwords)
#60477 by maja_ldm
Fri May 30, 2014 4:59 pm
How can I know if my laptop's EFI firmware is interfering with its optical drive functionality?

I'm having problems with the optical drive on my laptop. After some troubleshooting I started to be in doubt if the laptop's EFI firmware may be somehow involved because it seems the drive can't write an ISO to disk even using different operating systems. Anyhow the optical drive is recognized by the system and no errors are associated with it.

The optical drive is MATSHITA UJ8A0ASW and the laptop is ASUS N53SV. The laptops uses Aptio Setup Utility 2.01.1204 and the firmware has been updated to the last release published by ASUS on their official website (version 215). The optical drive's driver is Microsoft's 6.1.7601.18514, file version 6.1.7600.16385 (win7_rtm.090713-1255) and I can't find any update for it in the laptop's or the drive's manufacturer websites.

In Windows 7 Home Premium I tried to burn an iso image using Windows Disc Image Burner, InfraRecorder, running isoburn.exe (the process of Windows Disc Image Burner) from an elevated command prompt, using InfraRecorder with administration privileges, ImgBurn with administrator privileges and again Windows Disc Image Burner directly from the administrator account. In Debian/Linux I tried XfceBurn.

In all cases InfraRecorder and XfceBUrn completed the burning procedure but the disc was still empty, using Windows Disc Image Burner yelded "error:0x0AA0301" and using ImgBurn yelded "Power Calibration Area Error".
I ran Microsoft's Fix It utility to check the writing capabilities of the drive but the program didn't find any problem with the drive.
I ran Microsoft's dev-con utility and checked the system register, no lower or upper filters values are active on the device. Also, I didn't troubleshoot extensively in Debian/Linux, but the drive misbehaved in that operating system too.
If I ever used this computer to burn any other optical media it was a long time ago and I don't remember doing so, but I guess I already succesfully burned something at least before updating from BIOS version 212 to version 215.

I already burned my disc using another computer with Windows 8 and ImgBurn, I would like to know which kind of system check I can perform to verify what's the problem with the Panasonic drive in my laptop.
How can I know if there is a firmware problem or if I need to buy a new optical drive?