Don't ask how to hack password. (BIOS Passwords)
#56117 by ohaya
Wed Dec 15, 2010 5:49 am
Hi,

My son brought his Compaq Presario 2190US over, and it has multiple problems ...

I think that there's a problem with the power connector. I have to jiggle it until I can get it to power on. I'll fix that eventually, but that's not the reason for this post...

The problem is that when I do get it to power on, it is taking about 5 minutes to get to the initial HP screen.

Then (for example), if I select to go to Setup, it displays "Entering Setup" and then takes about 2 minutes to get to the BIOS setup.

In the BIOS setup, on the main screen, there are a number of fields (SERIAL, UUID, etc.) that have garbled characters.

So, I did a set defaults, then saved that, and the machine rebooted.

I configured a bootable floppy with the BIOS flash, and was able to boot to that, and it said that it flashed the BIOS successfully.

However, even after it rebooted the system, when it started, it again took about 5 minutes to get to the HP logo page, and when I go into BIOS setup (again 2 minutes more), it's still showing the garbled characters for the same fields.

Also, when the laptop is powered on, and (eventually) starts, it displays the memory test during the BIOS startup, but then there's a message before it boots into Windows or a bootable floppy:

WARNING: HP EEPROM has been re-initialized

I was really hoping that the BIOS flash would have taken care of the garbled characters, and mostly, the really slow boots, but it didn't, so I'm wondering what else could be causing that, and what to do about it?

FYI, I can get it to boot into Windows XP, and it runs fine under Windows. Also in the BIOS, I ran the hard drive test, and that worked ok.

Any ideas?

Thanks,
Jim