Don't ask how to hack password. (BIOS Passwords)
#28604 by Akronix
Wed Dec 08, 2004 6:21 pm
This is from an Averatec 3150H 12" notebook. The bios chip is a socketed PLCC SST39SF040, ami bios.

I believe I might have flashed the wrong bios from Averatec's 3120 model a few months ago. I don't know for sure because the NB won't boot now. It does go through what I believe to be the boot block procedure, but with only cdrom access (no floppy) and no video. I've tried several times to restore via boot block, but nothing I put on CD or any AMI procedure I tried would work. I might have corrupted the boot block with the bad flash.

I've tried hotflashing with uniflash on an older Packard Bell motherboard that had a PLCC socket. All I got was verification errors, which might be due to how old that PB motherboard is. The bios was 128k and the Averatec's is 512k, just too incompatable.

I'm currently trying with an Intel Pro/100 PCI card and it seems to work with uniflash, but I am still having some problems and am seeing some strange occurences. The info I got from the Intel nic came from this site... http://sandeen.net/fwfix/

First of all, Intel has some utilities that read and write the boot ROM on their nics, and using fboot from Intel only allows me to make a backup of the current image on my chip, write fails. Strange thing is the backup is 1024k in size while my bios chip is supposed to be 512k.

Uniflash doesn't detect the chip, so I have to use -force and the chip ID BFB7, but I am still getting verification errors.

Any thoughts? I'm kind of stumped here...