Don't ask how to hack password. (BIOS Passwords)
#36657 by ddigby
Fri Feb 10, 2006 9:46 pm
I have a gateway laptop running Phoenix BIOS. A few days ago I decided to set up a BIOS password. I set the supervisor password and I set a boot password. This worked as it is supposed to at the time.

Yesterday I noticed that it had stopped asking for the boot password. I went into the BIOS settings screen, which required the supervisor password as intended. The boot password was still shown as enabled. When I went to check it, it still had the pass I had set. I've tried changing it, clearing it then rebooting then resetting it, nothing I have tried so far has got it to ask for the boot password, and any search for the words BIOS and password together focuses on clearing a forgotten password.

I did repartition and set up Linux just before setting the password, but it worked fine and there is no real evidence to link the events. The only possible connection I can think of along those lines is that the grub bootloader is kicking in before POST reaches the point it needs to ask for the pass, but a)This doesn't actually seem possible, and b)It didn't happen initially.

Any advice would be greatly appreciated.