Don't ask how to hack password. (BIOS Passwords)
#41666 by jmlowe
Fri Oct 20, 2006 11:06 pm
I am 'converting' several TP600s to digital picture frames. Am using DSL in 'frugal' mode to drive the machines & image viewer, and to periodically poll for (& load) any new images that appear on any usb drive that is plugged in.
My image works fine---now I'm replacing the IDE hard drives with IDE/
Compact Flash adapters & 256MB Lexar CF chips.

TP600 #1 works flawlessly. Removed the HDD, installed adapter & CF card, booted, partitioned, formatted, loaded DSL, loaded my code on top--piece of cake.

TP390 (OK, one is not a TP600) thought the CF card was a 3GB drive, and although I was able to partition/format & load DSL & my image---it wouldn't boot. So after lots of web searching I changed the HDD parameters in BIOS to 'user' mode, 16 heads/32 sectors/978 cyls (=256MB), turned off UDMA----then reloaded and it works fine.

TP600 #2, 2645-41U: if the IDE/CF adapters isn't seated perfectly, the machine won't boot at all---I mean, the laptop won't even POWER UP. After some fiddling, I can get the machine to power up, but the BIOS can't see a hard drive of any kind (and of course, neither can linux).
So obviously I want to modify the BIOS on this TP600 to manually enter the disk parameters---and I have searched for almost three days and cannot figure out how to do it, nor have I found anyone else who has even posted an interest in doing this.


TP600 #3 appears to exhibit this same behavior


> I cannot find any other programs that I can use instead of IBM's goofy 'Easy Setup'
> I have installed the 'IBM ThinkPad Configuration Utility for DOS' (w/ bootable CD)---but this has no options for what I need (although I did depend on it to put the machines in 'presentation' mode so that the screens wouldn't turn off after an hour)---apparently the ONLY way to do that is the PS2.EXE program
> I know how to get into the 'System Configuration Edit Utility" in Easy Setup---but can't find the info I need to know what to alter.
> Possible to load an OLDER version of BIOS on the machine? I think the TP600s always had the Easy Setup utility, I'm worried that if I try to load BIOS for a completely different machine I'm going to introduce a host of OTHER issues...?
> I have run the IBM HDD firmware update---but it doesn't see a hard drive, so...no way to update the firmware (and there's no firmware in the CF card ANYWAY, but I was desperate)
> I have taken IDE/CF adapter & CF card from a working machine and tried it in machine #2---no luck (so the problem does not follow either the adapter or the CF card)

I have done due diligence in reading everything I can find, and still no answer. Surely I'm not the only one to have needed to do this...?

Any help would be appreciated,
Regards