Don't ask how to hack password. (BIOS Passwords)
#54111 by aroenai
Mon Dec 07, 2009 1:49 am
The bios for my Toshiba Satellite P105-S9722 has a wireless device whitelist and I haven't been able to get around it by editing known device ids. When I insert my new wireless mini-pcie card the laptop won't boot, I've tried changing the vales in bioscod3.rom to the ids for the Intel WiFi Link 1000 but it still doesn't work. The specifications pdf on toshiba's site says this laptop can also use Atheros wireless cards of some kind but I haven't been able to find those ids. I've been getting really frustrated with this and ideally I'd like to just nuke the whitelist check entirely like what's described here: http://www.endeer.cz/bios.tools/bios.html since I have no way of knowing what the actual values on the card are since I can't get past the stupid bios. I was also wondering if someone could help me find the token id for AHCI, I'm not very good with disassembly and the "trial and error" method with symcmos hasn't been working so far.

Here is my bios (Phoenix bios, v4.70 with Intel-vt support enabled):
http://s000.tinyupload.com/index.php?fi ... 1766378813

BIOSCOD3.ROM
----
Intel PRO/1000 PL (Ethernet)
PCI\VEN_8086&DEV_109A&SUBSYS_FF311179&REV_00
0x11d3: 86 80 9A 10

Intel PRO/Wireless 3945ABG (Wireless)
PCI\VEN_8086&DEV_4222&SUBSYS_10408086&REV_02
0x11dc: 86 80 22 42
0x134a: 86 80 22 42 (the wireless enable switch?)

I've determined that the possible ids for my Intel WiFi Link 1000 are:
VEN_8086&DEV_0083&SUBSYS_12058086 (Generic)
VEN_8086&DEV_0084&SUBSYS_12158086 (Lenovo)
VEN_8086&DEV_0083&SUBSYS_12258086 (Dell)