Don't ask how to hack password. (BIOS Passwords)
#53557 by naton
Mon Oct 05, 2009 1:19 pm
Hi there,
I have a gateway ML3108b laptop (AMD socket S1, North Bridge: nVidia C51MV, South Bridge: MCP51 )
My laptop has a Sempron CPU. I tried to upgrade it to a Turion X2 (same socket) and it didn't work. I tried a TL50, a TL52 and a TL60. Although they are correctly identified in the bios, the laptop display the following message "Fatal error! Change cpu" instead of loading the operating system.

My laptop uses a pheonix bios.

Initially I thought that my bios does not have Turion X2 microcodes. After spending days searching the web I did the following:

1- Extracted update0.rom from my laptop bios.
2- Extracted update00.rom from an HP dv9705 laptop bios. The dv9705 is originally shipped with a Turion X2.
3- Compared update0.rom and update00.rom with a hex editor.
4- I copied the content of update00.rom and added it to the beginning of update0.rom.
5- I recompilied my laptop bios using the updated update0.rom file (i.e. with the additional microcodes).
6- I flashed my laptop bios with the modded bios file.

My laptop is still working fine with the Sempron, but I still get the same error message when I try a Turion X2 on it.

Why the Turion X2 are still not working?
Was there another file that needed update apart from the update0.rom?
Do you think that Turion X2 are not working because of a chipset incompatibility? I mean because of hardware incompatibility and not a bios incompatibility?


thanks