Don't ask how to hack password. (BIOS Passwords)
#54154 by SolarScooter
Tue Dec 15, 2009 9:56 pm
Just posting this in case it helps someone else.

Short version:
Problem: Dell Latitude CPxH. Can enter, but cannot navigate BIOS setup screens; no response to keyboard whatsoever.
Solution: Remove 160GB hard drive; setup control restored.

Long version:

This old Dell CPxH had been a loaner to a friend when the MB died. I gave my friend a better loaner, and replaced the MB in the CPx with another off of eBay, since I liked the little machine and it had an XP license tied to it. Then I put in a 160GB Samsung drive with all of our music on it, dubbed the machine "The DellPod" and life went on.

Recently I attempted to enter the BIOS setup to change the boot order. Got to the first BIOS screen but there was no highlighted field and the machine wouldn't respond to any key presses including ESC. No changing pages with alt-p, no arrow keys, nuffin. Had to force it to quit with the power button.

So now I wondered if I'd got myself a duff board... yet I couldn't believe I wouldn't have noticed this before. The time and date were correct - I must've set 'em. So I tried re-flashing the existing BIOS (A13) and then flashed with the newest version (A14) without any trouble, but it didn't resolve the problem.

Finally I started pulling things out of the machine to see if there was a hardware conflict. Once the drive was removed, I was able to enter setup normally. (I also noticed that the service tag number appeared in its usual spot; when the setup utility is frozen, it doesn't show up.) I tossed in a smaller drive (40GB) and the setup utility still worked fine. Put the 160 back in, and it froze. So... I have a workaround. Machine works fine with the drive in, so if I need to fiddle with the BIOS, I'll pull it out temporarily.

As I said, I'm mainly posting this in the unlikely event that it helps someone else. However I'd sure be curious to know if anyone has any theories on this, or even if they've experienced it before. My first PC was a 10MHz XT clone, so I've been around the block once or twice -- but this is a new one on me.