Don't ask how to hack password. (BIOS Passwords)
#45340 by samov
Sun Jul 01, 2007 2:42 pm
Hello... i was having some problems with vista so i decided to upgrade the bios... thought M670 is the "main" product and M677 just a variation.... anyway i upgraded using the boot cd method with the file "1632_707.zip" from M670 and i should have upgraded it with "1633_707.zip" from M677.

The flasher did not give any errors and flashed without any warning. NOW the laptop powers on but the display is dead... "seems" to boot the bios in the background but i have no way of checking.

WHAT I'VE already tried:

THE AMI RECOVERY METHOD

i tried the floppy method... i had a usb floppy drive around...


1. copied the right bios image "A1633NMS.705" on the floppy disk.
2. renamed it to AMIBOOT.ROM
3. with the floppy connected, and while holding down Ctrl+home(key numer seven in on my keyboard) i powered on the laptop.
4. it started checking the floppy... AND then went into a loop reading ( light goes on 3 sec... pause 5 sec) for 10 minutes ( more than enough time to read and flash )

so i guess there is something wrong and it keeps checking for something.... might there be something wrong with the file NAME?

thanks

i checked the msi page... it's the AMI BIOS...

it responds to Ctrl+Home.... but seems to search for the file and does not find it.... did MSI change the name it should have?


tried the cd-rom method too.... it reads... then nothing the cdrom spin down.... then it just sits there doing nothing...

tried the memory stick method too... same thing ... reads.... then nothing


THE BLIND FLASH METHOD


here is what i did...

made a boot able cdrom using floppy emulation....

inside the image (floppy emulation image)

AFU408_D.EXE
amiboot.rom
AUTOEXEC.BAT
COMMAND.COM
CONFIG.SYS (empty)
IO.SYS
MSDOS.SYS

inside the autoexec.bat
"
a:\afu408_d.exe amiboot.rom /p /b /n /c /e /reboot
"

what i did:
1. took the hdd out to force cdrom boot....
2. inserted the cdrom
3. powered it up

results:
1. starts to read to cdrom... stops...
2. no action... for a prolonged period of time

questions:
2. i CAN "ctrl+alt+delete" to reset it ... what does this mean...?


i've found the bios chip... it's accessible... it's under de modem card near the wireless module....

it says...

WINBOND - W39L040P-70Z

i've found someone who can reprogram it for me... it's not worth going to warranty with it since... GOD KNOWS what they'll try to do to repair it and i can't exactly TELL them what i did... Cheesy ...

any ideas before i flash it?