Don't ask how to hack password. (BIOS Passwords)
#54503 by jools1976
Tue Feb 23, 2010 3:54 am
Hey folks, I have a problem here I'm hoping to get a hand with. I recently had an MSI M677 notebook with an AMI A1633NMS BIOS go pretty much dead on me. The power would still turn on, and the CPU fan would run, but that's it. No audio, no video, no beeps....nothing. After about a week of troubleshooting and otherwise messing around with it, I ended up using a POST code reader to come up with the following error code:

F1 -- The AMIBOOT.ROM file is not in the root directory

I then went to the MSI website and got the most recent BIOS for the notebook, and followed these steps:

1.Rename the desired AMI BIOS file to AMIBOOT.ROM and save it on a floppy disk. e.g. Rename A569MS23.ROM to AMIBOOT.ROM

2.Insert this floppy disk in the floppy drive. Turn On the system and press and hold Ctrl-Home to force update. It will read the AMIBOOT.ROM file and recover the BIOS from the A drive.

3.When 4 beeps are heard you may remove the floppy disk and restart the computer.

The only thing I did differently was use a USB stick instead of a floppy, and I heard no "4 beeps". I had no video so other than the activity light on the USB stick I had no way of telling what progress was being made on the reflashing. I left it about 20 - 30 minutes, rebooted, and everything worked perfectly. Now... I was using the laptop without a bettery (plugged into AC power), so after I got everything fixed up, I turned it off and put it aside for a few hours. I came back to it later and when I went to start it up, I had the same problem as before. I checked the CMOS battery and it was completely dead. I replaced it with a new battery, but now the flashing won't take. I am following the exact same steps I follwed before (that worked) but for some reason the activity light on the USB stick just keeps cycling on and off (in about 5 second on/off intervals). I've repeated the process 5 or 6 times, but nothing seems to work. I've left it running for over an hour... no flash. Can anybody help? Thanks.