Don't ask how to hack password. (BIOS Passwords)
#42236 by Creig
Wed Nov 29, 2006 4:09 am
I have a Compaq Presario 2500 that originally came with a desktop Celeron 2.0 GHz. I wanted to upgrade the processor and lower power consumption at the same time. The Celeron consumed a straight 60 watts and wasn't a SpeedStep processor, so it ran at 2.0 GHz all the time.

Since the Presario 2500 could originally come with a Mobile P4 (Northwood core), I assumed I could use a P4-M processor instead (Northwood core) because they are both SpeedStep processors using the same core and similiar voltages. The reason I went with the P4-M is because it uses 1/2 the power of a Mobile P4.

When desktop users installed a P4-M in a S478 motherboard, they were stuck with the 12x multiplier since desktop motherboards don't have SpeedStep support. I assumed that since both the Mobile P4 and P4-M are Northwood S478 SpeedStep processors that they would be interchangeable.

So now I have a 2.40 GHz P4-M installed. The only problem is that SpeedStep isn't working and I'm stuck at the 12x multiplier (1.2GHz). I've adjusted the Power settings, tried Notebook Hardware Control, tried SpeedSwitch... No help.

I think the laptop can handle the P4-M because when I exit the BIOS, I get a quick flash of the POST information that's not normally displayed during bootup. And it correctly displays "CPU = Intel (R) Speedstep (TM) Technology 2.40 GHz". So at least it's reading the correct processor information.

Does anybody know if I would need to reinstall XP since there was a non-SpeedStep processor in the laptop when XP was installed? Or is the SpeedStep software always installed and automatically activates when it detects a SpeedStep compatible processor/BIOS?

Or is it possible that this could be a problem with the BIOS not sending the correct information to Windows regarding SpeedStep since it didn't originally come a P4-M?

Or is there something else I haven't considered yet? I'd appreciate any help or suggestions.