Don't ask how to hack password. (BIOS Passwords)
#50001 by Spocky17
Mon Aug 04, 2008 6:34 pm
Today was the day... I tried to modify my bios of the HP NX5000.

First I wrote down the device ID and Subsys of the installed mini pci wlan card.

It was a Intel WM3B2100.

Then I put the notebook to suspend mode and changed the wirelss lan card with my new one.

This was a TP-Link WNX660. Then I wrote down this cards IDs.


After all I opened the bios file in this case it is a *.bin file with a hexeditor and searched for the device ID of the Intel 2100.

This was easy to find. But the subsys ID seams to be different than discribed in the tutorials.

The first 6 digits were the same like the original and then there came a code like F5 and then the last 2 digits.

Ok, so I thought I will try to change them with the IDs of my new card by not looking at the F5 code.


Everything changed, bios saved to file and then put on a floppy disk.


Flashing went fine and rebooting too.

But my new wlan adapter loaded up with the same error code on startup. I Think it is error code 104, but I am not sure.


Hmmm, what now...

First I flashed back my original bios to my NX5000.

Then I opended the bios.bin file again and searched for another wlancard in it.

Found one, seemed to be the original HP Compaq W400???

Compared the IDs with one of the IDs I found in the net and it matched.

But there was again the problem with some unknown code after the first 6 digits of the subsystem ID. This time it was FF.


Now I thought, I will try it by overwritting the FF with the last 2 digits of my new lan adapter subsys ID. :roll:


Meanwhile I hate me for doing this... :evil:


Again put the modified bios on the disk restartet the notebook and flashed it .


But after the restart my screen stayed black.

It seems to start normaly, but no picture is coming out..


Should I messed up with some graphics ID?

So I tried to flash via floppy, but it won't load from it.

If I put a bootable recovery cd in it, it starts spinning and loading from it. But purly it is not a recovery disk for this notebook.


Then I tried to make me a boot-cd by my own. Tested it in my other PC and it starts fine. But in my notebook it seems not working.


Is there any possibility to get access to my floppy again by pushing some buttons? I tried the method with win+b or fn+b and others, but it didn't work...


Then I read there are some notebooks where to set a boot block jumper.

But I couldn't find any info if it is neccassary with the NXe5000 too.


Maybe someone of you had the same problem and could give me some hint tothe right direction before spending money to burn a new flash bios.