search for manual of Supertek ST-3WT motherboard

Request help finding jumper settings or a motherboard manual.
Posts: 1914
Joined: Mon Oct 21, 2002 9:07 pm
Location: Germany

you'll need a ram module with 16Mx8 chips. same problem like the Intel 440BX chipset.
If you email me include [WIMSBIOS] in the subject.
The Hardware Archivist
Posts: 6286
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands


Do not assume anything

System error, strike any user to continue...
New visitors - please read the rules.
Posts: 2
Joined: Thu Oct 02, 2008 11:23 pm

Hi all,

I have the exact same thin client for a couple of years now and I was never
able to get it to work; all I could do was using the standard built-in Linux
environment by a company called EsESix from Germany (now taken over by HP).

My ThinClient uses a DiskOnChip 2000 16MB flash as storage for the Linux OS
and originally had 32MB of RAM.

Now I've put in a 256MB DIMM, which seems to work, but I'm still not able
to do anything with the device (other than connecting to my PC by using
a remote desktop/terminal service-shell).

I've found out that JP8 somehow changes the BIOS configuration.
Orinally jumpers were set at 1-2 and 7-8 which gave me no other choice
than to use the internal DiskOnChip drive.

Now I've discovered that by settings the settings to 7-8 and 9-10, I get the option
to boot from PXE (networkboot), which is a nice thing to investigate further.
If I don't PXE-boot, the system halts stating "NO SYSYEM DISK...".
(When set at those pins, you can alter the PXE settings by pressing F10
at startup)

Then I tried to connect an IDE harddrive to the IDE1 connector (the white connector
at the back-center), but that also doesn't work.

Can you guys tell me what the settings are at your JP8-block and how you
were able to run Windows on the thing...


Oh... and of course: a manual would still be welcomed :wink:
Posts: 1914
Joined: Mon Oct 21, 2002 9:07 pm
Location: Germany

connect the ide drive and detect it in the bios. make sure the IDE controller is enabled in the bios aswell. to prevent the device booting anything else you can remove the MD chip from its socket. it's the chip in the left lower corner of the mainboard. if you're unsure post the markings on the chips please.

i still don't recommend running windows on the machine because there are no drivers which support UDMA which results in a severe overall system performance loss. i'd install Linux with its UDMA drivers and a very limited x-server, a LCD and a IRDA remote or just a headless server (squid is running fine, too:)). in my opinion the machine is too slow to run XP at a reasonable speed anyway. but that shouldn't stop you from giving it a try ;)
If you email me include [WIMSBIOS] in the subject.
New visitors - please read the rules.
Posts: 2
Joined: Thu Oct 02, 2008 11:23 pm


Thanks for the reply.

I've been tinkering along and found out how to access the BIOS; I couldn't
manage in the first place, it always directly booted the DOC and I didn't
see any POST screen at start-up (not being able to enter the BIOS was my
primary problem).

By pressing the DEL-key lots of times I was finally able to enter the BIOS.
From there on, it was a piece of cake.

As a test I installed Windows 2000, but like you said, the thing is just too
slow to be really usefull running Windows.
I even found some audio, VGA and UDMA drivers, but the specifications are
just so limited that I'm thinking about using another OS instead.

My BIOS only allows me a maximum VGA-memory of 4MB, so maybe I'm
using a different BIOS version than theich.
After having re-read his post, I must have misinterpreted his mem-amount... :oops:

I also found out (I think) that JP8 is for the DOC address settings:
  • 1-2 , 7-8: C800
  • 1-2 , 9-10: CC00
  • 3-4 , 7-8: D000
  • 3-4 , 9-10: D400
  • 5-6 , 7-8: D800
  • 5-6 , 9-10 DC00
Somewhere on another forum I read that people were only able to use
one IDE device (as a master), but I had no problems using both master as
slave drives on the bus at the same time.


Post Reply