Toshiba satellite laptop stuck after BIOS update ?

Don't ask how to hack password. (BIOS Passwords)
Post Reply
New visitors - please read the rules.
Posts: 1
Joined: Thu Nov 12, 2020 10:57 pm

I have a Toshiba Satellite C55-B5298 that was working fine (Windows 10) until I updated BIOS from original (1.4) to last version (5.1). Stupid! Now it freezes on Toshiba logo screen. Power cycling starts automatic repair, diagnosing PC, I can eventually get to troubleshooting menu, advanced options. Startup repair didn't help. Restoring an older time point didn't help. I can start in safe mode OK and get to a normal windows desktop, but if I select "start in safe mode with networking", it freezes on the Toshiba logo screen again, even before the rotating circles start.

I tried CSM boot mode once, it wouldn't boot at all, so I switched back to UEFI mode. I took out battery and reset clock. No improvement. I had tried once to reload the bios firmware 5.1 from a thumb drive, but it didn't help, but I might not have done it correctly. I feel like the computer is almost ok, based on being able to boot to safe mode, but I don't know what to do next. I'd like to be able to use the laptop, I don't want to lose personal files and apps.
Post Reply