Don't ask how to hack password. (BIOS Passwords)
#23503 by majk
Tue Feb 10, 2004 7:48 pm
Model: Gericom Masterpiece 2540 XL 01/03 (G730 M9)
Configuration: P4 2.5, I845, FSB400, 512MB, ATI M9 64MB, HDD40GB, FTT 15,1' 1024x768, Combo Toshiba, NO FLOPPY
Purchased: Mediamarkt Austria (Villach), 04/2003

Problem description:
Recenty I flashed wrong bios .rom file. System is working,
but graphic don't work at all. Can't get picture
on FTT panel, secondary monitor or TVout.
Can't switch to sec monitor or restore screen with keyb function buttons.
System is sucessfuly booting form a bootabile CDROM,
even Windows XP from hard drive (i can hear the sound
after XP has started)
POST message: before memory beep sound, i can hear one long beep and two short beeps.

I suspect that i flashed wrong bios for G730 with ATI M7, not for G730 with ATI M9
from this page: http://www.airis-computer.com/SoporteCP ... s/N370.asp


Solution:
=> I tried to reset CMOS data (first dip switch from left) under keyboard => sucessfuly, but didn't help
=> I removed battery for few hours => didn't help
=> I tried to flash another BIOS (from old Gericom FTP) G7301212.bam [Ref.NO:G730-020503-OT-] => failed
=> I tried to flash with ECS original BIOS from: https://www.ecstsd.com.tw/temp/Notebook.asp => failed

For flashing i was using bootable CDs, because i have no floppy.
I tried another method named "Crisdisk" (with paralel port key) for Phoenix bios emergency procedures,
but that failed too. I don't know where is the problem.

Crisdisk: (http://www.phoenix.com/resources/userman.pdf)


11.12.2002 19:54 524.288 BIOS.ROM >>>>>>>> tried with: G7301212.bam (Gericom), g7300421.bae (ECS)
29.05.2000 13:13 32.000 CRISBOOT.BIN
07.05.2002 14:04 19.762 CRISDISK.BAT
12.12.2001 08:38 12.803 MAKEBOOT.EXE
29.05.2000 13:13 2.688 MINIDOS.SYS
10.10.2001 20:16 75.296 PHLASH.EXE >>>>>>> from Gericom ftp
03.03.2002 22:17 1.182 PLATFORM.BIN
8 File(s) 668.019 bytes

I used instructions for making crisdisk and parallel port key form: http://www.charmed.com/PDF/jumptec-bios-update.pdf


=> I used latest version of phlash.exe and original platform.bin
=> platform.bin is equal (binary checked) in ECS, Andromeda and Gericom BIOS releases
=> Crisdisk CD is booting, but after few short beeps system halts and restarts
=> i suspect that system can't recognize old original bios and flash it back

=> I am from Croatia, and here is no Gericom service or distributer that can help me since my laptop is from Österich.
=> I am an advanced computer tehnician and I will understand any of your complicated instructions, since no one can help me here.


=> i know it is my fault and my warranty is useless now, but it is a good and expensive computer.


=> where can i find ORIGINAL release Gericom G730 M9 bios .rom file (perhaps you can send it to me by e-mail)
=> how to FORCE flash it back with (maybe automated boot disk) and where can I find it?
=> on gericom FTP there is no downloads for G730, why?

Thank you!