Updating VBIOS

Video, SCSI, modem, CDROM/CDR/CDRW, etc.
Equinox
New visitors - please read the rules.
Posts: 7
Joined: Fri Jan 12, 2007 4:57 am

Fri Jan 12, 2007 5:16 am

Alright so i just got a new 19" Widescreen LCD Monitor. I'm using a Gigabyte motherboard [GA-8S661GXMP-RZ], with an onboard SiS 661FX GFX chipset. I don't see any resolution of 1440x900 in my display settings. But apparently SiS says on their site that it does, and that i need the latest driver version [which i have, triple checked], and the latest VBIOS version, which i don't. My VBIOS version is 2.02.00 and i need to update it to 2.28.00. Basically, I was hoping if someone could help me out with locating the VBIOS update and updating my VBIOS. Thanks.
KachiWachi
The New Guy
Posts: 1451
Joined: Fri Mar 29, 2002 10:32 pm
Location: Pennsylvania, USA

Fri Jan 12, 2007 3:16 pm

The Video BIOS is either located on the video card itself, or "attached" to the main PC BIOS (if integrated).

It sounds like yours is integrated.

Does Gigabyte offer an updated BIOS for you?
cp
BIOS Guru
Posts: 1914
Joined: Mon Oct 21, 2002 9:07 pm
Location: Germany

Fri Jan 12, 2007 6:28 pm

USE AT YOUR OWN RISK:
modified bios with latest sis bios

the latest sis vga driver should update your vga bios as well (TSR style)
Equinox
New visitors - please read the rules.
Posts: 7
Joined: Fri Jan 12, 2007 4:57 am

Fri Jan 12, 2007 8:17 pm

I have flashed my motherboard firmware bios already, and its the latest version right now, which i got from gigabyte's website. I updated the VGA driver lots of times, rolled back to earlier version and back and forth a couple of times again as well [clean installs]. But apparently, the VBIOS is still the same version as before, it hasn't updated.

From the SiS website, i downloaded uniVGA3 [3.73] and [3.77], i installed the latest 3.77 version, and there are alot of sis bin files in my system32 folder [and in the \uvga3_377\3.77logo\WinXP_2K\ folder as well] right now [650.bin, 660.bin, sis740.bin, sis741.bin, 760.bin].

In the sisgr.inf file, i see this:

HKR,, SiS.2D.EnableCRTMode1920_1200, %REG_DWORD%, 0x00000001
HKR,, SiS.2D.EnableCRTMode1440_900, %REG_DWORD%, 0x00000001
HKR,, SiS.2D.EnableCRTMode960_600, %REG_DWORD%, 0x00000001
HKR,, SiS.2D.EnableCRTMode1280_800, %REG_DWORD%, 0x00000001
HKR,, SiS.2D.EnableCRTMode1680_1050, %REG_DWORD%, 0x00000001
HKR,, SiS.2D.EnableLCDMode1280_800, %REG_DWORD%, 0x00000001
HKR,, SiS.2D.EnableCOPP, %REG_DWORD%, 0x00000000

I don't know if its relevant or not, but i thought i should paste it here, just in case.


I really appreciate you guys helping me out, cuz i was really freaking out that i'd have to return this monitor for a standard size 19" LCD, but i'm kinda new to all this bios stuff, so if someone could please tell me where do i put the 661gxmp.bin or like how to flash the vga bios, it'd be a great help guys!
cp
BIOS Guru
Posts: 1914
Joined: Mon Oct 21, 2002 9:07 pm
Location: Germany

Sat Jan 13, 2007 12:42 pm

the file i supplied is the motherboard's firmware with the latest sis vga bios (F2 bios with updated sis6330.bin). you can flash it like you flashed the original version from gigabyte.
those .bin files are the video bios files. you can inject them into the mainboard's bios with 'cbrom' (that's exactly what i did).
Equinox
New visitors - please read the rules.
Posts: 7
Joined: Fri Jan 12, 2007 4:57 am

Mon Jan 15, 2007 5:10 am

That file wasnt the latest VBIOS for my SiS 661FX/GX, anyone here who can find the latest VBIOS for me? My Board manufacturer has such a shitty support service that they havent even replied to my mail yet, which i sent them about 4 days ago!
edwin
The Hardware Archivist
Posts: 6227
Joined: Wed Mar 20, 2002 7:11 pm
Location: Netherlands
Contact:

Mon Jan 15, 2007 8:59 am

http://www.sis.com/support/support_faqs_4.htm
3. If your VBIOS version is not 2.28.00 or later, you have to update your BIOS, please contact your board maker or system provider to get BIOS update support.
SiS not gonna give it to you, prod Gigabyte about it.
edwin/evasive

Do not assume anything

System error, strike any user to continue...
Equinox
New visitors - please read the rules.
Posts: 7
Joined: Fri Jan 12, 2007 4:57 am

Mon Jan 15, 2007 2:00 pm

Yes, by Board Manufacturer, i meant Gigabyte. I dropped them a msg almost 4-5 days ago, and still havent heard anything from them! Its annoying as hell! I need to locate the latest VBIOS asap!
KachiWachi
The New Guy
Posts: 1451
Joined: Fri Mar 29, 2002 10:32 pm
Location: Pennsylvania, USA

Mon Jan 15, 2007 2:36 pm

Do you actually think they will drop everything and service your e-mail in 4-5 days?

Give them some time...and realize that they may never respond to your request.

It sounded like cp hooked you up...what exactly was wrong with his patch?

Thanks.
cp
BIOS Guru
Posts: 1914
Joined: Mon Oct 21, 2002 9:07 pm
Location: Germany

Mon Jan 15, 2007 6:42 pm

mainboard manufacturers get other versions than sis is using in their driver releases. don't ask why, i don't know. actually the sis 0.65.00 version is dated 01/19/2006. the 2.02.00 version that gigabyte used is dated 07/16/04. sis version numbers are lower but the build date is newer. go figure out for yourself.
Equinox
New visitors - please read the rules.
Posts: 7
Joined: Fri Jan 12, 2007 4:57 am

Mon Jan 15, 2007 10:00 pm

KachiWachi; Yes, I realize that they may not respond at all, and i don't know how many days do they need, cuz mostly i get a reply within 2-3 days from other support services, like Blizzard Ent. for example.

As for cp's patch, it is 0.65.00 version, it didn't fix my problem, i still cant get 1440x900 resolution for my monitor. Either SiS' website states wrong that the chipset supports the Widescreen resolution, or that BIOS version isn't the latest...
cp
BIOS Guru
Posts: 1914
Joined: Mon Oct 21, 2002 9:07 pm
Location: Germany

Tue Jan 16, 2007 12:40 am

okay, i found the SIS video bios 2.49.00 (date is 03/15/06 btw. :)) and modded it into the bios. use at you own risk!

GA-8S661GXMP-RZ F2 with SIS 2.49.00 video bios
Equinox
New visitors - please read the rules.
Posts: 7
Joined: Fri Jan 12, 2007 4:57 am

Tue Jan 16, 2007 5:06 am

Yay! Lets hope this one works, I'll load this bad boy up when i get back from college. I'll reply back when its done.
Equinox
New visitors - please read the rules.
Posts: 7
Joined: Fri Jan 12, 2007 4:57 am

Tue Jan 16, 2007 3:03 pm

Alright!! It worked! VBIOS version 2.49.00, and running on 1440x900@75Hz :D

Thanks alot guys!

CP; Can i ask where did you find that bios anyways?
cp
BIOS Guru
Posts: 1914
Joined: Mon Oct 21, 2002 9:07 pm
Location: Germany

Tue Jan 16, 2007 3:45 pm

yeah, great! :)

i shamelessly ripped out the 2.49.00 from an ASRock K7S41(GX) bios. you can get it here:
http://www.asrock.com/mb/download.asp?Model=K7S41

they updated the video bios in mainboard bios version 2.30. so you can find it in all releases after 2.30
they also have P4 boards with the same vga core but other chipset. there they didn't bother to touch the video bios to get around the 1440x900 quirks..*sigh*
Post Reply